[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Sparc installations

	Hi Eric,
	I installed Debian Sparc/Linux in two Sparc 4. Until yesterday cant get
X running. Thanks to you, I'm running X now. Great! :) Count with me to report
any problems in Debian Sparc. I just loved running Linux into these old Sparc.
Great work guys.
	Have a nice day,		Paulo Henrique
Quoting Eric Delaunay (delaunay@lix.polytechnique.fr):
> John Chapman wrote:
> > This weekend I installed (in a fairly minimal configuration) Debian Linux on
> > two Sparcs: one LX and one SS2.  I've got a few questions, several comments,
> > and don't know whether one should file bug reports for a work in progress,
> > so I'll post this here, in the hope that some kind soul will shove me in the
> > right direction.
> > 
> > Most things in the installation worked quite well.  There were a couple of
> > problems with the SS2, though;  I had put a brand new drive into it, and
> > (perhaps because of this?) the installation program didn't want to partition
> > and format the drive, but kept bouncing me back to the "select a color or
> > mono monitor" screen.  I ran fdisk and mke2fs from the vc2, did network
> > config by hand, and copied the files over onto one of the partitions via an
> > nfs mount, but the installation program still wouldn't let me mount the
> > partitions.  Finally I guessed that I should mount /dev/sda1 to /target, and
> > everything suddenly worked.  I'm quite at a loss to explain why this can be
> > done by hand, but not by the menu interface.  (Incidentally, this was with
> > the tftpboot image.)  A possible bug in the installation program?
> For sure :-((
> The installation program is providing its own fdisk parser (libfdisk it is).
> It may fail on garbage in the partition sector of the disk... I didn't
> experienced with this problem and I don't have time to fix it now. Sorry.
> The workaround is to run fdisk manually then the installation program should
> stop to segfault after the system has reread the partition table of your hard
> drive.  Are you sure you needed to run all the steps by hand ?
> > The floppy installation on the LX didn't have this problem (but, then, it
> > had a previously-used hard drive.)  I didn't try out all of the disks; at
> > the "install from a mounted partition" point, I did  an nfs mount of the
> > base set, and continued from there.  There was no long delay in searching for
> > the drivers or base set at all.  However, both on the SS2 and the LX, the
> > "insert drivers into the kernel" step fails; the program complains about not
> > being able to find sed (I counldn't find it, either), and, as a result,
> > nothing on the drivers floppy gets added.  I'm not sure if it should, yet,
> It will be fixed in the next bootdisks release.
> > and I don't miss much except the serial ports, which don't get configured at
> > all.  Perhaps someone can give me some tips.
> >
> > Other problems:  "more" is immediately broken, since the ncurses package is
> > a more recent version, and there is no package with the old version still
> > available.  I use "less" all the time, anyway, but this may also have broken
> > other things in the utils package.  I can't reinstall it, since the package 
> > depends upon the old ncurses library; should I just make a symlink for now?
> > Or recompile them?   gcc and friends seem to work OK (I tried them out once on
> > "frotz"), which is a very good sign indeed.
> In fact, util-linux is out-dated and should be recompiled.
> # dpkg -I util-linux_2.7.1-3.deb
> ...
> Pre-Depends: libc6 (>= 2.0.91), ncurses3.4
> ...
> > Since I was downloading packages ad libitum, I didn't try running dselect or
> > apt, so I can't report (or complain) about them.  I have noticed a couple of
> > little things which need fixing, though:
> > 
> > jed requires jed-common; the Packages listing states that this is in
> > binary-sparc, but it's in binary-all.  The same applies to tetex-base, and
> > several others.
> Not a problem at all because all binary-all packages are symlinked to each
> binary-<arch> tree.
> # cd slink/main/binary-sparc/editors
> # ls -l jed-common_0.98.7-14.deb
> lrwxrwxrwx   1 root     root           49 Jan 21 21:25 jed-common_0.98.7-14.deb -> ../../binary-all/editors/jed-common_0.98.7-14.deb
> > X fails with complaints about the lack of /dev/kbd.  Is this something which
> > gets made with a proper dselect installation?  I would run makedev, but I've
> > noticed that the Other Distribution assigns /dev/kbd the major number 11,
> > minor 0, which is scd0 with Debian, and I'd rather leave it alone until I
> > know what the Right Thing To Do is.  And there's probably some marvelous
> > Debian package which sets up everything correctly, anyway :-)
> Aargh :-(( In fact I lose the fixes I made to MAKEDEV to handle sparc specific
> devices for the base system.  I fixed the stuff in place, so it was
> overwritten by a new makedev package when I did an upgrade and I completely
> forgot to send a patch to the maintainer.  Grrr :-((
> I will rewrite it for the next bootdisks release.  They will provide /dev/kbd,
> /dev/fb* & /dev/sunmouse in the base system.
> BTW, /dev/kbd is really major 11, minor 0 but *char* device while /dev/scd0 is
> major 11, minor 0 and *block* device.
> Try the following commands to create missing devices:
> # mknod /dev/kbd c 11 0
> # mknod /dev/fb0 c 29 0
> # mknod /dev/sunmouse c 10 6
> > All in all,  I'm quite impressed and delighted that so much works so smoothly.
> > And I suppose I should volunteer to help in some way.  Any suggestions?
> We don't have enough testers to discover the broken packages.
> Would you want to be one of them ?
> Thanks for your report.
> -- 
>  Eric Delaunay                 | "La guerre justifie l'existence des militaires.
>  delaunay@lix.polytechnique.fr | En les supprimant." Henri Jeanson (1900-1970)
> --  
> To UNSUBSCRIBE, email to debian-sparc-request@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: