[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian Sparc installations

This weekend I installed (in a fairly minimal configuration) Debian Linux on
two Sparcs: one LX and one SS2.  I've got a few questions, several comments,
and don't know whether one should file bug reports for a work in progress,
so I'll post this here, in the hope that some kind soul will shove me in the
right direction.

Most things in the installation worked quite well.  There were a couple of
problems with the SS2, though;  I had put a brand new drive into it, and
(perhaps because of this?) the installation program didn't want to partition
and format the drive, but kept bouncing me back to the "select a color or
mono monitor" screen.  I ran fdisk and mke2fs from the vc2, did network
config by hand, and copied the files over onto one of the partitions via an
nfs mount, but the installation program still wouldn't let me mount the
partitions.  Finally I guessed that I should mount /dev/sda1 to /target, and
everything suddenly worked.  I'm quite at a loss to explain why this can be
done by hand, but not by the menu interface.  (Incidentally, this was with
the tftpboot image.)  A possible bug in the installation program?

The floppy installation on the LX didn't have this problem (but, then, it
had a previously-used hard drive.)  I didn't try out all of the disks; at
the "install from a mounted partition" point, I did  an nfs mount of the
base set, and continued from there.  There was no long delay in searching for
the drivers or base set at all.  However, both on the SS2 and the LX, the
"insert drivers into the kernel" step fails; the program complains about not
being able to find sed (I counldn't find it, either), and, as a result,
nothing on the drivers floppy gets added.  I'm not sure if it should, yet,
and I don't miss much except the serial ports, which don't get configured at
all.  Perhaps someone can give me some tips.

Other problems:  "more" is immediately broken, since the ncurses package is
a more recent version, and there is no package with the old version still
available.  I use "less" all the time, anyway, but this may also have broken
other things in the utils package.  I can't reinstall it, since the package 
depends upon the old ncurses library; should I just make a symlink for now?
Or recompile them?   gcc and friends seem to work OK (I tried them out once on
"frotz"), which is a very good sign indeed.

Since I was downloading packages ad libitum, I didn't try running dselect or
apt, so I can't report (or complain) about them.  I have noticed a couple of
little things which need fixing, though:

jed requires jed-common; the Packages listing states that this is in
binary-sparc, but it's in binary-all.  The same applies to tetex-base, and
several others.

X fails with complaints about the lack of /dev/kbd.  Is this something which
gets made with a proper dselect installation?  I would run makedev, but I've
noticed that the Other Distribution assigns /dev/kbd the major number 11,
minor 0, which is scd0 with Debian, and I'd rather leave it alone until I
know what the Right Thing To Do is.  And there's probably some marvelous
Debian package which sets up everything correctly, anyway :-)

All in all,  I'm quite impressed and delighted that so much works so smoothly.
And I suppose I should volunteer to help in some way.  Any suggestions?

Reply to: