[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

SILO bootable cdrom troubles (second run)


  I'm still having troubles to making SILO bootable cdrom.
My first attempt was using mkisofs, intelsilo & cdrecord on my PC box.  I
tried silo 0.8.1 then silo 0.8.5 with no success at all.
SILO refused to load the initial ramdisk from my written CD.
I got "Internal error while loading physical blocks from device" errors.

My next attempt was to connect my cdrecorder to my sparc box (it's a Yamaha
4260 with the blocksize jumper, therefore I can connect it to a sparc) and run
the whole process of building & writing CD image on sparc side.
I used silo 0.8.5, mkisofs 1.12b4 & cdrecord 1.8a9 on an uptodate Debian system.
I can boot from the CD now: silo is loading the kernel & the ramdisk, but
linux is not able to boot from the loaded ramdisk.  It gives the following

  RAMDISK: Couldn't find valid ramdisk image starting at 0.

then switch to netboot :-(

Here is my silo.conf file:

# linux + ramdisk


and the following contents of the CD image:

-rw-r--r--   1 root     root         1024 Jan  5 21:42 boot/cd.b
-rw-r--r--   1 root     root         1062 Jan  9 18:17 boot/debian.txt
-rwxr-xr-x   1 root     root      1607596 Dec 30 00:37 boot/linux
-rw-r--r--   1 root     root      2867200 Dec  8 07:24 boot/root.bin
-rw-r--r--   1 root     root        49120 Jan  5 21:44 boot/second.b
-rw-r--r--   1 root     root           80 Jan  9 19:30 boot/silo.conf

I didn't find a complete explanation on how to using the initrd parameters of
silo.  Did I miss something in silo.conf ?

I'd appreciate any help.
Thanks in advance.

PS: if it can help, my sparc is a SparcClassic and the kernel I run is
    sparclinux 2.0.35 with RAMDISK, INITRD, NFSROOT & ISOFS support compiled in.

 Eric Delaunay                 | "La guerre justifie l'existence des militaires.
 delaunay@lix.polytechnique.fr | En les supprimant." Henri Jeanson (1900-1970)

Reply to: