[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Please test: Netscape 4.73 packages with CJK support


after trial and error, I finally succeeded to launch Netscape with CJK

The information I provided was too insufficient. I'm sorry
for that. Here is a more detailed version of the environment I'm using:

locale: zh_TW.Big5
wm:	KDE (from http://kde.tdyc.com, I can't update my KDE there, why?)
xfs-xtt running and xfont-arphic-bsmi001p installed

Netscape failed because the arphic fonts were not running in X as
'FontPath "unix/:7100" ' was not included in XF86Config. After amending
XF86Config, I could see the arphic fonts by running xlsfonts. However, the
whole system suspended when I launched netscape. All the CPU resources
were used by the xserver. 

But now, everything works fine since I initialize the xsession by adding
the argument '-deferglyphs 16' (What does this mean?) Netscape now looks
great with menu in Chinese and I no longer see any strange alignment of
Chinese words when I type in it. 

One minor problem is that strange characters are still shown at the top of
the window. Can it be fixed? Anyway, it looks wonderful. I am grateful for
all your contribution. Thanks a lot!!

Lincoln Leung

On Mon, 10 Jul 2000, Anthony Fok wrote:

> On Tue, Jul 11, 2000 at 12:14:05PM +0800, Lincoln Leung wrote:
> > 
> > It was installed. Any other solution for this? Thanks.
> Try these commands, xlsfonts and xfd, to see if your system can see the
> fonts:
> $ xlsfonts -fn '-default-ming-medium-r-normal--14-*-*-*-*-*-big5-0'
> -default-ming-medium-r-normal--14-135-75-75-c-0-big5-0
> -default-ming-medium-r-normal--14-140-72-72-c-140-big5-0
> $ xfd -fn '-default-ming-medium-r-normal--14-*-*-*-*-*-big5-0'
> (this should display up the fonts.)
> Are you running xfs-xtt?  These Chinese TrueType fonts need xfs-xtt
> (X-TT X Font Server), otherwise they won't be displayed.
> You also mentioned that you are using KDE.  My question is: where did you
> get KDE?  From http://kde.tdyc.com/ ?  Or did you compile it yourself?
> If it still fails, try:
>     $ LANG=zh_TW.Big5 LC_ALL=zh_TW.Big5 LC_CTYPE=zh_TW.Big5 netscape
> BTW, how had you been starting Chinese Netscape?  Via the KDE menu
> "Netscape (zh_TW.Big5)", or did you start it from a command prompt?
> And finally, you are using a Debian potato/woody system, right?
> Thanks,
> Anthony
> -- 
> Anthony Fok Tung-Ling                Civil and Environmental Engineering
> foka@ualberta.ca, foka@debian.org    University of Alberta, Canada
> Debian Chinese Project -- http://www.debian.org/international/chinese/
> Come visit Our Lady of Victory Camp -- http://www.olvc.ab.ca/

| This message was re-posted from debian-chinese@lists.debian.org
| and converted from big5 to gb2312 by an automatic gateway.

Reply to: