[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

network-manager applet disappeared

Yesterday. that is 14 dec 2019,
On debian9 system, using fluxbox
ASUS K52N --- 10 year old

I installed nmap, and then updated my system by apt update; apt upgrade
Run nmap once ( -sn option ONLY (that is only ping-scan)) on my OWN router to see who was connected ...
Then browsed web ( official sites of universities )

this was a prologue, to clarify the situation
-- those were the only actions I took in a long time on this system.

( Using fluxbox and in its init file I do start nm-applet by "nm-applet &" ...
this worked flawlessly ... until now )

Today after starting my system, nm-applet was present, but when I clicked on it, it said "network-manager not started" --or something along those lines ... sorry I cant remember
(essentially, I was just unable to recieve an IP address --- the router does NOT allow me to use static IP addresses)
I run top (as i often do), and for some reason dpkg is using a lot of cpu (10%) which is not usual on my system. After a while it stopped.
I restarted my system, "nm-applet" was NO LONGER in my system, "nmcli" was also NOT present.
bash is unable to find "nmcli, nm-applet, nm-connection-editor"

Could this be a work of virus?   or am I too paranoid
Could this be a result of usage of nmap on such old laptop ?

If this was not appropriate mailing list to send this mail, I apologise ...

Reply to: