[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Updated Apache packages for testing?

I've had this problem before with apache spontaneously seg faulting when trying to execute it. I know we all hate killing the uptime but if I rebooted it would solve the problem.


John Foster wrote:
John Foster wrote:

Well..... I had been having some wierd issues with Apache since my last
upgrade in Woody. I decided to go ahead and get the new security
upgrades. No problem with the install but I am now getting these
messages when I try to start Apache. Any suggestions as my server is
down completely at present. Not a happy camper:-(

root# apachectl start
/usr/sbin/apachectl: line 171:  1628 Segmentation fault      $HTTPD
/usr/sbin/apachectl start: httpd could not be started

root# apache-sslctl start
/usr/sbin/apache-sslctl: line 171:  2195 Segmentation fault      $HTTPD
/usr/sbin/apache-sslctl start: httpsd could not be started

root# apache -v
Server version: Apache/1.3.24 (Unix) Debian GNU/Linux
Server built:   Apr 30 2002 06:00:09

------------------------SOLVED PROBLEM---------------------------
Ran dpkg-reconfigure apache then I ran apacheconfig and only used DSO
modules. This got me up and running again but.... I need some of the
other modules loaded that were commented out when /etc/apache/httpd.conf
was rewritten. Anyone know of a way to get either dpkg or apacheconfig
to go thru the modules that I have installed and re integrate them into
/etc/apache/httpd.conf without doing each one by hand.

To UNSUBSCRIBE, email to debian-security-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: