Re: PETSc tight dependency on OpenMPI (or MPICH) version
On Tue, 2016-06-28 at 05:37 +0000, Mattia Rizzolo wrote:
> well, based on the value of $(MPI) you can make a dependency on
> libopenmpi-dev or libmpich-dev, if you want (I don't think you need).
> > Any thoughts on how we could improve that, while keeping the build-
> > dependency on the general mpi-default-dev rather than the specific
> > implementation of MPI?
> The only way to improve that is imho to write up some craziness to
> the dependency on libopenmpi1.10, so you get
> libopenmpi1.10 (>= 1.10.3), libopenmpi1.10 (<< 1.10.4)
> or something like that. This will prevent the installation of a
> non-camptible libopenmpi, and will also prevent the testing migration
> openmpi until petsc is rebuilt for the new patch release.
That sounds like the best way to proceed. We don't want an $(MPI)
mechanism in the Build-Depends, since at build-time we want to use
whatever is the latest standard MPI, as loaded by mpi-default-dev.
But in the specific libpetsc*-dev packages we should add a versioned
depends on the "libmpi" package. I can use an $(MPI) mechanism for
that, filling in whichever mpi version that mpi-default-dev loaded.
> A lot saner way to improve the situation, is to figure why the hell
> petsc needs such a thing, and do something to stop it.
A worthy longer term goal :)