[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#680484: gmap and scotch: error when trying to install together


On Mon, Jul 16, 2012 at 05:57:09PM +0200, Radostan Riedel wrote:
> On Mon, 16. Jul 16:20, Andreas Tille wrote:
> > > >    debcheckout --user tille git://git.debian.org/debian-science/packages/scotch.git --git-track '*'
> Hi Andreas,
> have you tried just using:
> git pull
> Just tried and I'm getting Christophe's latest commit when I clone the repo. 
> Maybe a bug in debcheckout?

Perhaps it was just me because I expected a changelog entry besides the
changes (which where actually in the repository).  Due to some reason I
do not remember I found another clone on my harddisk which contained an
*uncommited* changelog entry - perhaps I have worked together with
Christophe on this on the Debian Science workshop and just forget to
commit.  Whatever, this issue seems to be solved.

I also incorporated the changes of a previous NMU which was not commited
into Git.  Unfortunately as a Git beginner I had no idea how to do this
properly with the correct history / tag magic and so I simply pushed the
changes in to have no regression in the package.  If somebody would
volunteer for the tagging of the NMU that would be fine for me.
> > Same for me - I have no idea why Git sometimes makes some fun with me
> > and hides information.  Even if I know a lot of people who are much
> > in favour of it it seems to be quite picky about its friends and it
> > not yet considers me as one of them. :-(
> > 
> > I'm also missing the pristine-tar branch as it should be there according
> > to Debian Science policy.
> True. There is no pristine-tar branch. Maybe it was never pushed?

May be - how could I know?
> Btw: I'm also no git expert. I'm having my own hard time with git sometimes :D.

Finally it was probably me - but it is good if you have something to
shout about for the moment. ;-) 

Kind regards



Reply to: