[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: specifying virtio block device as root filesystem for Debian S390X install?


Thanks for the reply - 

it turns out that since I was running the Debian 9/stretch kernel/initrd, it
was not loading the ext3/4 modules due to missing modules.  This is likely
the reason why partman failed to give me an option to make the filesystem.
I had to boot the machine up on the Debian 8/jessie kernel/initrd, shoehorn
in the netcfg_1.134_s390x udeb to get rid of that virtio eth0 error, and
then mess with the dasd postint to bypass the DASD designation.  However, I
was able to get partman working and got the filesystem doing, and it's
installing the base system now, so I suppose that it is okay.  
Thanks and regards, 

-----Original Message-----
From: Philipp Kern [mailto:pkern@debian.org] 
Sent: Monday, November 02, 2015 4:38 AM
To: kkwan.nyc@gmail.com
Cc: debian-s390@lists.debian.org
Subject: RE: specifying virtio block device as root filesystem for Debin
S390X install?


On 2015-11-02 00:24, Kevin Kwan (Personal) wrote:
> I actually do run into fatal errors if I run this on my Debian x64 
> machine, but I think it's possible issues with the S390X TCG in the 
> older builds of QEMU - actually have both the Windows and Linux 
> version running side-by-side
> - the Windows version does get me further...although I do suspect 
> other issues down the line.

qemu master actually segfaults[1] if you try to use s390x. [2] hopefully
fixes that (untested).

> How did you deactivate the s390 postinst on the installer shell?

You can go back to the menu, go down and "Execute a shell". Then edit
/var/lib/dpkg/info/s390-dasd.postinst with nano and add an "exit 0" 
after the shebang.

I did push a fix to s390-dasd[3] yesterday night. If you use the unstable
udebs, you should get it. Otherwise in five days. With that it will simply
exit if there's no DASD channel found on the bus. I think that we could
stuff that into stable as well.

> The interesting side-bit is that I tried to define the machine as a 
> virtio-ccw machine using the following command, and then define the 
> disk and networking as channel devices:
> qemu-system-s390x.exe -machine type=s390-ccw-virtio-2.5 -m 512 -kernel
> kernel.debian9 -initrd initrd.debian9 -hda linux.dsk -device
> virtio-net-ccw,netdev=net0 -netdev user,id=net0 -k en-us -redir
> tcp:9022::22
> I was able to define it, but Debian cannot initialize it on boot 
> (virtio_ccw
> 0.0.0000: Failed to set online: -5), so that's a bit of a dead end.

Yeah, I had the same issue back in August. With current qemu and current
kernel (4.1 worked, but also 4.2) it worked for me.

Kind regards
Philipp Kern


Reply to: