[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: specifying virtio block device as root filesystem for Debin S390X install?

Ah, I actually ran the Windows port of qemu (http://qemu.weilnetz.de/) - the
build that I used was the latest build (2.4.50, 20150925).  
The command line that I used was the following:

qemu-system-s390x.exe -machine type=s390-virtio -m 512 -kernel
kernel.debian9 -initrd initrd.debian9 -drive
file=linux.disk,if=none,id=disk0 -device
virtio-blk-s390,drive=disk0,id=virtio-disk0 -device
virtio-net-s390,netdev=net0 -netdev user,id=net0 -k en-us -redir

I actually do run into fatal errors if I run this on my Debian x64 machine,
but I think it's possible issues with the S390X TCG in the older builds of
QEMU - actually have both the Windows and Linux version running side-by-side
- the Windows version does get me further...although I do suspect other
issues down the line.  
How did you deactivate the s390 postinst on the installer shell? 	

The interesting side-bit is that I tried to define the machine as a
virtio-ccw machine using the following command, and then define the disk and
networking as channel devices:

qemu-system-s390x.exe -machine type=s390-ccw-virtio-2.5 -m 512 -kernel
kernel.debian9 -initrd initrd.debian9 -hda linux.dsk -device
virtio-net-ccw,netdev=net0 -netdev user,id=net0 -k en-us -redir tcp:9022::22

I was able to define it, but Debian cannot initialize it on boot (virtio_ccw
0.0.0000: Failed to set online: -5), so that's a bit of a dead end.  

-----Original Message-----
From: Philipp Kern [mailto:pkern@debian.org] 
Sent: Sunday, November 01, 2015 5:54 AM
To: Kevin Kwan (Personal)
Cc: debian-s390@lists.debian.org
Subject: Re: specifying virtio block device as root filesystem for Debin
S390X install?

On Wed, Oct 28, 2015 at 08:47:51PM -0400, Kevin Kwan (Personal) wrote:
> Is it possible to specify a virtio block device as a root filesystem
> the Debian s390x installer?   I specified a virtio disk for
> qemu-system-s390x, and through some miracle was able to get the virtio 
> networking up and running via the latest debian s390x kernel/initrd, 
> and had no issues up until the disk partitioner.  The partitioner was 
> able to see the disk (/dev/vda) and allows partitions to be created 
> (vda1/2/etc), but it does not allow it to be used.  The partition 
> disks section only allows the option of swap space, physical volume for
encryption, and "do not use".

I wonder how you got into the disk partitioner in the first place. All my
tries caused fatal errors in the DASD configuration part and it wouldn't let
me proceed. So s390-dasd will need a fix to detect this situation. After I
deactivated s390-dasd's postinst, it proceeded into the installer and
offered all filesystem options. (I'm not saying that the result would work,
just that the partitioner created filesystems

How did you invoke qemu? (Which seems to be incredibly fiddly, especially at
HEAD.) What version?

Kind regards
Philipp Kern

Reply to: