[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#726733: av_register_all() segfaults on s390x in some cases (regression, causes FTBFS)



tags 726733 help
stop

On Tue, Jan 14, 2014 at 11:09 PM, Reinhard Tartler <siretart@gmail.com> wrote:
> Mostly for my own reference, I noticed this from the buildlog
> https://buildd.debian.org/status/fetch.php?pkg=libav&arch=s390x&ver=6%3A9.10-2&stamp=1388850961:
>
> env LD_LIBRARY_PATH="/usr/lib/s390x-linux-gnu/libfakeroot:/usr/lib64/libfakeroot:/usr/lib32/libfakeroot:/«PKGBUILDDIR»/debian/tmp/usr/lib/s390x-linux-gnu"
> \
> debian/tmp/usr/bin/avconv -formats | tee formats-s390x.txt
> Segmentation fault
> env LD_LIBRARY_PATH="/usr/lib/s390x-linux-gnu/libfakeroot:/usr/lib64/libfakeroot:/usr/lib32/libfakeroot:/«PKGBUILDDIR»/debian/tmp/usr/lib/s390x-linux-gnu"
> \
> debian/tmp/usr/bin/avconv -codecs | tee codecs.txt
> Segmentation fault
>
>
> This is supposed to fail the build, but doesn't. I guess the | tee is
> hiding the problem.

I've again tried to reproduce this issue today, but was unable to do
so on zelenka, avconv worked just fine in the s390x chroot. This makes
me wonder if zelenka was maybe configured differently?

In any case, looking at the buildlogs on s390x on
https://buildd.debian.org/status/logs.php?pkg=libav&arch=s390x, it
becomes clear that libav never worked on s390x (while it did on s390;
look for the string "segmentation fault" in the build log). To make
this clearer, I've fixed the package to no longer hide the segmenation
fault, that is, make the package build fail
(https://buildd.debian.org/status/fetch.php?pkg=libav&arch=s390x&ver=6%3A9.11-2&stamp=1393250404).

I'm therefore going to ask ftp-master to remove the broken binaries
from unstable, as like this bug shows, the s390x binaries are severly
broken.

Nevertheless, dear s390x porters, please help with fixing this issue.

Thanks.

-- 
regards,
    Reinhard


Reply to: