Re: parser vs ruby_parser gems
On 2020, മാർച്ച് 12 7:58:34 PM IST, Antonio Terceiro <firstname.lastname@example.org> wrote:
>On Thu, Mar 12, 2020 at 07:05:42PM +0530, Pirate Praveen wrote:
>> On 2020, മാർച്ച് 12 12:28:52 AM IST, Kiran Skunjumon
>> >their is two gem parser and ruby_parser.
>> >In debian ruby_parser is packaged under ruby-parser instead of
>> >parser is a dependency of unparser .
>> >now i am stuck
>> I think we can use the github username (like we did earlier and a
>common practice for forks) to create a unique name for the new package.
>So we can package parser gem as ruby-whitequark-parser.
>In this case it's not really a fork, it's a problem with our naming
>convention. We should stop making exceptions for gems whose names
>with "ruby[-_]*, and make ruby_foo become ruby-ruby-foo, not just
>IMO it would be better to fix the name of existing package now instead
>of postponing this. It would be
>- rename ruby-parser to ruby-ruby-parser
>- introduce parser as ruby-parser, adding Breaks: against versions of
> the packages that currently dependend on ruby-parser wanting the
> "ruby_parser" gem.
> $ reverse-depends ruby-parser
> * gitlab
> * obs-api
> * roodi
> * ruby-html2haml
> * ruby-ruby2ruby
> Those packages would need to be adjusted to depend on ruby-ruby-parser
OK I'll start with renaming ruby-parser to ruby-ruby-parser and follow the steps once it is accepted in the archive.
Sent from my Android device with K-9 Mail. Please excuse my brevity.