[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#594480: ipset from xtables-addons-common/sqeeze requires iptables/sid



On Tue, 2010-11-09 at 17:43 +0100, Pierre Chifflier wrote:
> On 08/30/2010 10:22 AM, Pierre Chifflier wrote:
> > On Thu, Aug 26, 2010 at 02:06:23PM +0400, Sergey Ptashnick wrote:
> >> ipset from xtables-addons-common 1.26-2 (sqeeze) requires shared library
> >> libxtables.so.5, that provided only by iptables 1.4.9-1 from sid,
> >> not 1.4.8-3 from sqeeze. Please add this dependency and request to update
> >> iptables in sqeeze from sid.
[...]
> Short summary: xtables-addons from squeeze was included while it was
> built with a recent version of iptables-dev (1.4.9 at least). However,
> version from squeeze is 1.4.8.
> 
> The solution is to trigger a rebuild of package xtables-addons with the
> current versions of the squeeze tools.
> Can you trigger a rebuild, or redirect me to the best way of doing this ?

I've scheduled binNMUs in testing to fix this.  To stop it happening
again, however, would it make sense for xtables-addons-common's
dependency on iptables to indicate the minimum required version?  (I'm
not sure if there's an easy way of doing that more elegantly than just
using the version of iptables-dev against which it was built).

Regards,

Adam


Reply to: