[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

fglrx 8-12 for Lenny

Hash: SHA1


We the fglrx maintainers think, that it would be the best to release
lenny with 8-12-x instead of 8-7-3. it fixes many bugs like the X11
crash bugs with wine, missing 2.6.26 kernel support and a bunch of
another upstream issues has been addressed. also the packaging itself is
now much cleaner (patch system instead of a self hackish one etc) and
some more or less documentation fixes.
The changeset is in opposite to the lenny candidate a bit bigger, see below.
It also fixes two quite important bugs (clashing diversions: #475007 and
bashishm: #489575)

The last two noted bugs could also be fixed by a 8-7-4 upload, but I
hope we may release it with 8-12.

Any objections?


fglrx-driver (1:8-12-2) UNRELEASED; urgency=low

  [ Patrick Matthäi ]
  * Add new diversion in fglrx-driver to libglx.so.
    Closes: #510496
  * Remove diversions of package fglrx-driver on remove.
  * Bump dependencies to match with the xserver-xorg 7.4 release.

  [ Romain Beauxis ]
  * Tightened diversion removal in fglrx-glx only libGL.so related
  Closes #475007

 -- Romain Beauxis <toots@rastageeks.org>  Fri, 02 Jan 2009 20:03:47 +0100

fglrx-driver (1:8-12-1) experimental; urgency=low

  * New upstream release. Closes: #508819
    - No more dri problems like in the 8-11 release.
      Closes: #506000
    - It should build fine now with Linux 2.6.27.
      Closes: #496318
    - Remove deprecated patches.
      Closes: #508024
    - This release fixes some crashes on starting/playing videos with
      like kaffeine and mplayer.

      Closes: #489254

    - Remove 13-fix_debian_485605.patch which is fixed in this release.

  * Add myself to uploaders.

  * Add DM-Upload-Allowed control flag.

  * Install the x740 libs, so fglrx could be used with xserver 1.5. If
    still use xserver < 1.5 then you have to set it back to x710 in


  * Fixed bashishm in the acpi fglrx-powermode.sh script.

    Closes: #489575

  * Remove fuzzy 14-deletes_unecessary_spaces.patch.

  * Adjust path to index.html in README.hacking.

  * Add missing ${misc:Depends}. Thanks lintian.

  * Remove odd debian/TODO.

  * Fit debian/README.hacking to the up to date and easy
    to build the original tarball.

  * Change to dpatch instead of a self-hackish one and migrate the
    to it.

  * Correct typo in debian/rules PHONY.

  * Bump debhelper compatibility level to 7, so we can use dh_lintian.

  * Override shlib-with-executable-stack lintian warning.

  * Change short descriptions to also supporting r7xx cards in this

 -- Patrick Matthäi <patrick.matthaei@web.de>  Thu,  1 Jan 2009 17:17:02

fglrx-driver (1:8-10-1) experimental; urgency=low

  [ Bertrand Marc ]
  * New upstream release. Closes: #500077
  * Fixed corruption with windows wider than 1760
    pixels. Closes: #450426
  * Fixed AGP Aperture Size in BIOS. Closes: #451973
  * Fixed double free corruption when running fglrxinfo
    or any 3d apps. Closes: #454751
  * Fixed corruption with Xvideo overlay. Closes: #361694
  * Fixed DRI init and CMMQS driver init. Closes: #464667
  * Fixed failure with fglrxinfo. Closes: #497543
    thanks to Patrick Matthaei for testing these old bugs.

  [ Romain Beauxis ]
  * Set distribution to experimental for now.

 -- Romain Beauxis <toots@rastageeks.org>  Tue, 11 Nov 2008 15:55:54 +0100

Just the xserver-xorg 1.5 foo has to be dropped from this changeset.

- --
Mit freundlichem Gruß / With kind regards,
Patrick Matthäi

E-Mail: patrick.matthaei@web.de

Always if we think we are right,
we were maybe wrong.
Version: GnuPG v1.4.9 (GNU/Linux)


Reply to: