[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Base system installation errors in testing due to libldap

Russ Allbery wrote:
> Frans Pop <elendil@planet.nl> writes:
>> For amd64 at least I'm currently getting installation errors due to the
>> fact that both libldap2 and libldap-2.4-2 are in testing and getting
>> installed, which results in:
>> libldap-2.4-2: Conflicts: libldap2 but 2.1.30.dfsg-13.5 is to be
>> installed
>> Could someone please look into this?
> That would imply that something in the base system is still built against
> the OpenLDAP 2.1 libraries and probably needs to be binNMU'd.  (And the
> current OpenLDAP packages desperately need another maintainer with time to
> work on them, but that's a different problem.)

I think that libldap2 may just need its priority reduced. AFAICT it is being 
installed because it is "important".

I can find only 2 packages that depend on it for amd64/testing: libaws2.2 
and libhugs-ldap. But I don't think either of those is relevant for a base 
installation (or even normal desktop installs).

Given that, maybe even removal would be an option, but I'll leave that to 


Attachment: signature.asc
Description: This is a digitally signed message part.

Reply to: