[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bugs that'll block python 2.5

On mar, 2008-04-15 at 12:46 +0200, Piotr Ożarowski wrote:
> [Josselin Mouette, 2008-04-15 12:32]
> > The solution is really simple, just add them to python’s Provides: list.
> python2.5 package already does that

But python does not:
Provides: python-email, python-xmlbase

> , the problem was that python-support
> generated something like "python (<<2.5)" for "2.1-2.4", anyway, Depends
> are filled in by hand in python-wsgiref package and I will file a bug in
> python-support after work.

This behavior is intentional; if python-foo only supports python << 2.5,
introducing a dependency on python (<< 2.5) | python2.4 will just break
all python-foo’s reverse dependencies, allowing them to be installed
with python 2.5 while they can’t work with it.

Thus, there needs to be some special-casing for modules being moved to
core python packages. As they are doomed to be removed soon enough, I
think they can live with some manual dependencies.

: :' :      We are debian.org. Lower your prices, surrender your code.
`. `'       We will add your hardware and software distinctiveness to
  `-        our own. Resistance is futile.

Attachment: signature.asc
Description: Ceci est une partie de message =?ISO-8859-1?Q?num=E9riquement?= =?ISO-8859-1?Q?_sign=E9e?=

Reply to: