[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bugs that'll block python 2.5

[Josselin Mouette, 2008-04-15 12:32]
> On lun, 2008-04-14 at 22:57 +0200, Adeodato Simó wrote:
> > Finally, and quite importantly, there is what to do with modules that
> > have been added to the standard library in 2.5 (ctypes, celementtree,
> > wgsiref). These use either pycentral or pysupport, and since they mark
> > themselves as for python << 2.5 only, the dependency generated is on
> > python (<< 2.5), rendering them uninstallable.
> The solution is really simple, just add them to python’s Provides: list.

python2.5 package already does that, the problem was that python-support
generated something like "python (<<2.5)" for "2.1-2.4", anyway, Depends
are filled in by hand in python-wsgiref package and I will file a bug in
python-support after work. In python-ctypes there was a different
problem - XS-Python-Version's content was wrong (I changed "all" to
">=2.1, <<2.5")

Reply to: