[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bugs that'll block python 2.5

* Josselin Mouette [Tue, 15 Apr 2008 12:28:00 +0200]:

> On lun, 2008-04-14 at 22:57 +0200, Adeodato Simó wrote:
> > Finally, and quite importantly, there is what to do with modules that
> > have been added to the standard library in 2.5 (ctypes, celementtree,
> > wgsiref). These use either pycentral or pysupport, and since they mark
> > themselves as for python << 2.5 only, the dependency generated is on
> > python (<< 2.5), rendering them uninstallable.

> The solution is really simple, just add them to python’s Provides: list.

That's a good point, but that's about rdepends only, and orthogonal to these
packages being uninstallable.

Anyway, FTR, all three packages have been uploaded like this:

 python-wsgiref (0.1.2-3) unstable; urgency=medium
   * Replace ${python:Depends} with "python (<<2.5) | python2.4,
     python-support (>=0.6.4)" as python-support generates wrong dependencies
     (and makes this package uninstallable with python2.5 set as default)

 celementtree (1.0.5-10) unstable; urgency=low
     - don't use ${python:Depends} in depens fields so
       that the package can coexist with python >= 2.5 (Closes: #475897)

 ctypes (1.0.2-3) unstable; urgency=medium
   * Change "all" to "<<2.5" in XS-Python-Version and let python-central
     generate dependencies, add python2.4 to Depends (closes: #475906)


Adeodato Simó                                     dato at net.com.org.es
Debian Developer                                  adeodato at debian.org
                              Listening to: Carlos Berlanga - Septiembre

Reply to: