[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Question about removal of cyrus-sasl2-mit

On Mon, 2006-12-11 at 10:49 -0800, Russ Allbery wrote:
> Wait, woah.  You shouldn't just remove libsasl2-gssapi-mit from etch
> without a transition package so that people who are upgrading from sarge
> still have the MIT GSSAPI SASL module installed.  That would break a bunch
> of our servers.
> I agree with the removal since the base SASL libraries are now newer and
> the old modules may well not work, but we should provide a better upgrade
> path than just having the package disappear.

Say no more.

I made a small mistake in the current package -- I made it provide
libsasl2-gssapi-mit. I forgot that virtual packages have to be agreed
upon beforehand. So that Provides has to be removed. I'll take care of

I'll also take care of versioning the Conflicts and Replaces, and adding
a Conflicts: libsasl2-gssapi-mit to libsasl2-2.

Sam, do you have time to change libsasl2-gssapi-mit into a dummy package
that depends on libsasl2-modules-gssapi-mit? Or would you prefer me to
do it?

Sorry for the trouble,
Fabian Fagerholm <fabbe@paniq.net>

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: