[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: The shlibs files of slang1a-utf8 and slang1 in sid specify dependendencies not fullfillable in sarge, although the packages was not uploaded in time for the base freeze.


Yes, the version of slang in sarge needs to be bumped to 
include the shlibs fix in sid. I'd misread the deadline
as being the last day for uploads to _sid_ rather than the
last day for transitions to _sarge_. 

The depends were overly strict; it would be sufficient for >> 2 rather than

Unfortunately bug #264080 (filed against whiptail) appears to
be due to changes in slang. I am debugging this now. If a
fix is required to slang, I will upload a new slang to 
testing-proposed-updates, otherwise Steve Langasek agreed to
just transition slang to sarge.


>Sorry for the overlong subject. ;-)
>It has been brought to our attention that slang breaks the base
>freeze, because any package linking against slang uploaded to sid
>now cannot propagate to sarge because the slang's shlibs have been
>bumped. slang 1.4.9dbs-4 and -5 were uploaded on 26 Jul 2004 with
>urgency=low therefore without any chance of making the base-freeze
>I have tried to understand why 1.4.9dbs-5 forces (>> 1.4.9dbs-4)
>dependencies in its shlibs file but the only change in the source-code
>between 1.4.9dbs-3 and 1.4.9dbs-5 is the bugfix for #260898 exactly as
>posted by Colin Watson in the BTS. And I completely fail to see how
>this patch can change the ABI.
>              cu andreas[2]
>[1] whitespace broken due to c'n'p, apply with patch -l.
>[2] No I am no release manager but
>"See, I told you they'd listen to Reason," [SPOILER] Svfurlr fnlf,
>fuhggvat qbja gur juveyvat tha.
>Neal Stephenson in "Snow Crash"

Reply to: