[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Packages not moving to testing

On 2004-05-16 ehikory@mail.goo.ne.jp wrote:
>     I've just been looking at the http://bjorn.haxx.se/debian/
>     output, and found a number of packages that might be able to go
>     into testing with a little help.  I'm not very familiar with the
>     hinting process, so I would appreciate if someone could
>     translate these into the appropriate hints, or alternately
>     explain why the situation in currently unresolvable.

>     The following packages render themselves uninstallable when
>     entering testing, and also have an unfufillable Java dependency.
>     Isn't this allowed for contrib?

> charva/1.0.1-3 needs j2sdk1.3 | j2sdk1.4
> libitext-java/1.02b-3 needs java2-runtime
> jetty/4.2.19-1 needs j2re1.3 | j2sdk1.3 | j2re1.4 | j2sdk1.4 | java2-runtime
> rhdb-explain/2.0-1 needs j2re1.4 | java2-runtime
> freeguide/0.7.2-2 needs j2sdk1.4 | java2-runtime

It is allowed but the testing scripts do not handle it.

>     The following packages render themselves uninstallable when
>     entering testing:

> batick/1.5final-3

There is no package named batick in debian.

> libxtm-perl/0.36-1

The new version is uninstallable, it conflicts: perl (>= 5.8). Afaict
from the rationale in
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=221076 and
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=167181 this is
intentional and the package should be removed from sarge.

remove libxtm-perl/0.36-1

> snes9express/1.42-1

snes9express depends on snes9-x which is only available on i386 and
powerpc, but snes9express was built on all archs, and is therefore
uninstallable everwhere but on i386 and powerpc.

> stardict/2.4.3-1

Broken depends:
# stardict (1.9.92+2.0.0-pre2-3.1 to 2.4.3-1)

    * Maintainer: Roy Hiu-yeung Chan
    * 50 days old (needed 10 days)
    * stardict-tools/alpha unsatisfiable Depends: libc6 (>= 2.3.2.ds1-4)
    * stardict-tools/ia64 unsatisfiable Depends: libc6 (>= 2.3.2.ds1-4)
    * Valid candidate 

ia64 and alphac use libc6.1 instead.

Ouch. The package hardcodes this in the diff.gz. RC bug submitted.

> xmmplayer/0.3.3-1

Depends: mplayer.

> mplayerplug-in/2.60-1

Depends: mplayer

> xfree86-driver-synaptics/0.13.0-1

uninstallable on s390. known problem, being worked on.
             cu andreas

"See, I told you they'd listen to Reason," [SPOILER] Svfurlr fnlf,
fuhggvat qbja gur juveyvat tha.
Neal Stephenson in "Snow Crash"

Reply to: