[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Accepted kdeplasma-addons 4:4.4.4-1 (source all amd64)

On Tuesday 01 June 2010 13:27:59 Ivan Čukić wrote:
> On Tuesday, 1. June 2010. Debian Qt/KDE Maintainers wrote:
> >    * Merge liblancelot0 into plasma-widget-lancelot. liblancelot.so.0
> >    broke
> > 
> > ABI without bumping a soname in KDE SC 4.5 again.
> Hi our friendly KDebian maintainers,
Hi Ivan

> Anyhow, liblancelot has no ABI-stability planned for the foreseeable
> future, but from KDE SC 4.6 not only plasma-widget-lancelot will depend on
> it - the Shelf applet, now a part of lancelot's build will move out since
> it can be used even w/o plasma-widget-lancelot installed.

We are not requiring a stable ABI, but a stable ABI within the same SOVERSION, 
which is what everyone with libraries with installed public headers should be 
doing, or alternatively stop installing public headers.

We have stopped shipping the liblancelot headers, and with only one consumer 
currently of liblancelot, there is no reason to keep it separate for now.

Man, how to telnet from the back-end?

First from Explorer 2.8 and from Windows you must unlink the TCP program to 
boot from a printer.

Reply to: