[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#481584: [ksmserver] KDE update 3.5.5 -> 3.5.9 ksmserver not updated, blank screen when starting X

Package: ksmserver
Version: 4:3.5.9.dfsg.1-2+b1
Severity: normal

--- Please enter the report below this line. ---

First: I don't use any display manager, I start X with the startx command.

The problem occured when I installed Gwenview, KPhotoAlbum and digiKam. At 
this point I was running a KDE 3.5.5 setup and I used 

apt-get install gwenview kphotoalbum digikam

This caused several other KDE packages to be updated to 3.5.9, among them 
kdebase-bin, kdelibs4c2a, kdesktop etc.

Next time I started X with startx I got a black screen with a mouse pointer, 
nothing else. Clicking and keystrokes didn't cause any reaction.
I first updated kwin from 3.5.5 to 3.5.9 wich didn't have any effect. After 
updating ksmserver from 3.5.5 to 3.5.9 the KDE session starts again and 
everything runs as normal.

I think that there is a dependency missing between ksmserver and some of the 
basic KDE packages so that if those are update ksmserver gets updated too.

--- System information. ---
Architecture: i386
Kernel:       Linux

Debian Release: testing/unstable
  500 unstable        mirrors.ecology.uni-kiel.de 
  500 unstable        ftp.nerim.net 
  500 unstable        ftp.at.debian.org 
  500 stable 

--- Package information. ---
Depends                             (Version) | Installed
kdelibs4c2a                      (>= 4:3.5.9) | 4:3.5.9.dfsg.1-4
kwin                 (= 4:3.5.9.dfsg.1-2+b1)  | 4:3.5.9.dfsg.1-2+b1
 OR x-window-manager                          | 
libc6                              (>= 2.7-1) | 2.7-5
libgcc1                                       | 1:4.2.1-6
libice6                          (>= 1:1.0.0) | 1:1.0.1-2
libqt3-mt                       (>= 3:3.3.8b) | 3:3.3.8b-5
libsm6                                        | 1:1.0.1-3
libstdc++6                      (>= 4.1.1-21) | 4.2.1-6
libx11-6                                      | 2:1.0.3-5
libxau6                                       | 1:1.0.1-2

Reply to: