[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#586605: firmware-b43-installer: do not fail on kernel version mismatch

2011/1/27 Fabrizio Regalli <fabreg@fabreg.it>

> firmware-b43-installer currently fails in postinst script on kernel versions <
> 2.6.25. This makes impossible to install firmware-b43-installer in the
> deboostrapped environment, since it may not have a kernel at all, but the host
> system has 2.6.18 or similar. postinst script should ask if it's ok to install
> firmware-b43-installer anyway (like udev does).

from NEWS file:

b43-fwcutter (1:011-5) unstable; urgency=high

 * This version of the package installs the firmware suitable for
kernels >= 2.6.25. It will do so unconditionally on upgrades and this
break usage with 2.6.24. If you for some reason still want to use
2.6.24, please backup your "old" /lib/firmware/b43.

A kernel greater than (or equal) 2.6.25 is required otherwise the
firmware will not work.

My suggest is to close this bug.

Nope, one again: installation of firmware-b43-installer will fail in a debootstrapped environment (NOT a host system). For example, host system has 2.6.18, debootstrapped system doesn't have kernel at all. At this time I cannot install firmware-b43-installer in debootstrapped system. Postinst script should determine the debootstrapped system (based on comparing root inodes like it's done in udev's postinst) and bypass kernel check in such system, and (probably) show a warning that it fail to work on < 2.6.25, so it will be my headache to provide a suitable kernel for my debootstrapped system.



Regards, Krasu

Reply to: