[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#412952: [Fwd: Bug#412952: file conflicts between afnix and aleph]

Could I have some advice about the best way to fix this one please? Here's
a summary:

* The obsolete package "aleph" is supserseded by "afnix".
* I've requested the removal of aleph from unstable (bug #389163).
* There is already another RC bug against "aleph", as it conflicts with

I didn't make afnix "Replaces:" aleph because aleph is scheduled for
removal. I guess I should have done? What would be best - uploading a new
version of  afnix, or marking this bug as blocked by 389163?


---------------------------- Original Message ----------------------------
Subject: Bug#412952: file conflicts between afnix and aleph
From:    "Michael Ablassmeier" <abi@grinser.de>
Date:    Thu, March 1, 2007 8:00 am
To:      submit@bugs.debian.org

Package: afnix, aleph
Severity: serious
Justification: file conflicts between packages, policy violation


both afnix and aleph do ship several files of eachother but do not
conflict or add a diversion, thus fail to be installed on the same

 Unpacking aleph (from .../aleph_0.9.0-3_amd64.deb) ...
 dpkg: error processing /var/cache/apt/archives/aleph_0.9.0-3_amd64.deb
  trying to overwrite `/usr/bin/axc', which is also in package afnix
 dpkg-deb: subprocess paste killed by signal (Broken pipe)
 Errors were encountered while processing:
 E: Sub-process /usr/bin/dpkg returned an error code (1)

full list of files conflicting:


    - michael

Reply to: