[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#349295: memprof bug

Justin Pryzby wrote:
Hey Jason,

Can you confirm the ability to run "xterm" under memprof?  I agree
that memprof seems to be totally busted, but it seems to at least be
capable of spawning an xterm, if nothing else.  I just want to check
and see if we are seeing the thing.  Another bug was submitted

  #349453: memprof hangs just after executing profiled app

I noticed you are running a sid system; does memprof functionality
change at all if you apt-get update && apt-get dist-upgrade today?

I can run `memprof -- xterm` and the xterm does load. However I can't profile or do a leak check on it; it gives errors like:

** (memprof:23125): WARNING **: Can't open /proc/23132/mem

** (memprof:23140): WARNING **: Can't open /proc/23141/stat

and if I do anything inside memprof, the *xterm* is likely to hang.

When I run a GTK program (like Abiword) I get this message on startup of memprof:

memintercept (23162): _MEMPROF_SOCKET = /tmp/memprof.pPq3aN
memintercept (23162): New process, operation = NEW, old_pid = 0

and the program window never opens. In fact I get this message if I run `memprof -- true`, though I can't profile or leakcheck this program either (and there's no way to tell when it actually exits).

None of this appears to be changed by doing a dist-upgrade.


Reply to: