[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#349295: memprof bug

On Sun, Jan 22, 2006 at 11:45:51PM -0500, Jason Dorje Short wrote:
> Justin Pryzby wrote:
> >Hey Jason,
> >
> >Can you confirm the ability to run "xterm" under memprof?  I agree
> >that memprof seems to be totally busted, but it seems to at least be
> >capable of spawning an xterm, if nothing else.  I just want to check
> >and see if we are seeing the thing.  Another bug was submitted
> >tonight:
> >
> >  #349453: memprof hangs just after executing profiled app
> >
> >I noticed you are running a sid system; does memprof functionality
> >change at all if you apt-get update && apt-get dist-upgrade today?
> I can run `memprof -- xterm` and the xterm does load.  However I can't 
> profile or do a leak check on it; it gives errors like:
> ** (memprof:23125): WARNING **: Can't open /proc/23132/mem
I don't get that, I just can't get any kind of result except for
xterm being slow.

> and if I do anything inside memprof, the *xterm* is likely to hang.
I don't think I saw that.

> When I run a GTK program (like Abiword) I get this message on startup of 
> memprof:
> memintercept (23162): _MEMPROF_SOCKET = /tmp/memprof.pPq3aN
> memintercept (23162): New process, operation = NEW, old_pid = 0
> and the program window never opens.  In fact I get this message if I run 
> `memprof -- true`, though I can't profile or leakcheck this program 
Yup; same here.

> None of this appears to be changed by doing a dist-upgrade.
Okay, thanks.

Clear skies,

Reply to: