[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: python 2.2 -> python 2.3 transition

On Wed, Aug 13, 2003 at 02:14:55PM +1000, Donovan Baarda wrote:
> > Actually, all that have that are now uninstallable.  Some important ones
> > have that, such as libwxgtk2.4-python.  
> > 
> > Shouldn't they depend on python2.2 instead
> No. There is a reason they are not installable... they don't work with
> python (2.3)

But they do with Python 2.2... why not let them at least be installable with
that version?

As an example, in OfflineIMAP, I write:

Depends: python2.2, python2.2-twisted, python2.2-pyopenssl
Suggests: python2.2-tk

(Yes this differs slightly from what's in the archive; it's from my svn

Now, I could do the dependency on python (>= 2.2), python (<<2.3) thing. 
But what would that gain me or users?  I see no benefit there, other than
people tracking sid would find OfflineIMAP uninstallable until it gets
updated to depend on Python 2.3.

There are plenty of OfflineIMAP users that don't use Python themselves,
don't care that it's written in Python -- and probably some that don't
*know* it's written in Python.

(And yes, the bang path explicitly calls python2.2)

> Fortunately, most "python-foo" packages are simple wrappers that have
> "Depends: python2.2-foo", so they are very small and easy to "fix" for
> python (2.3) (changed to "Depends: python2.3-foo").

That makes a lot of sense to me, and I have no quibble with that approach. 
If libwxgtk2.4-python took that approach, I'd have no complaints as I could
still install and use the lib under Python 2.2.  As it is, that is
impossible, even though the lib remains compatible with Python 2.2.

-- John

Reply to: