[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#982742: cups: config of usb printer now impossible due to usblp and libusb conficting (used to work!)

Am Mon, 15 Feb 2021 18:57:44 +0000
schrieb Brian Potkin <claremont102@gmail.com>:

> ...
> siduction is based on Debian unstable, so, if (A) and (B) are fully
> uo to date, the printing systems should be identical. You have shown
> that ipp-usb works fine on the siduction installation. That is what
> (to me at least) is so puzzling.

The same goes for me. That's the situation which drove me crazy the
last year. I was about to buy a new printer ... until, as a
last-ditch attempt I wrote this bug report. So thanks again.
> I realise you are now happy with your printing situation, so thanks
> for continuing to engage with this ipp-usb issue.

Sure. See above ;-)
But the thing that makes me hesitant is the following: I migrated his
installation multiple times from one partition and disk to another. And
it once had serious systemd problems during a dist-upgrade due to the
drive giving up slowly. I could
repair/overwrite/reinstall/whatever-one-would-call-it this installtion
years ago. And it worked since. But I can't exclude there's a sutble
flaw hidden in some corner.
On the bright side: The printer worked the first years.

> ...
> > (B) There is a flaw somewhere within this installation which
> > *affects* ipp-usb without ipp-usb neccessarily being the cause.  
> A fair assessment.

> ... 

> > The same on the problematic installation (B) with ipp-usb
> > reinstalled and rebooted:
> > 
> > $  lp -d OKI_B432_010E46_USB_ ~/.bashrc
> > lp: Error - The printer or class does not exist.
> > 
> > ~$ lp -d OKI_DATA_CORP_B432 ~/.bashrc
> > Anfrage-ID ist OKI_DATA_CORP_B432-5 (1 Datei(en))
> > 
> > but NO print. And in the cups joblist the same long known error:
> > 
> > "Warte darauf dass der Drucker verfügbar wird."
> > Waiting for the printer to become available
> > 
> > And the printer's little LCD is showing: Ready to print.
> > 
> > And the moment I purge ipp-usb again, the printer starts to
> > print without the job being sent again.  
> Just to clear up something: would you stop ipp-usb on (B):
>   systemctl stop ipp-usb
> Do you get an output from 'lpstat -l -e'?

# systemctl stop ipp-usb

# lpstat -l -e
OKI_DATA_CORP_B432 permanent

> ...

> The file I downloaded has the PPDs under the General Public License.

Didn't know PPD is text. You are right. That's in contrast to what the
linked document on the website says. All the better. I updated my
wishlist bug accordingly.

> Cheers,
> Brian.



Reply to: