[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Some questions, plus hfsprogs is missing

Hello James,

On 25/04/2021 18:01, James Madgwick wrote:
On Sun, 25 Apr 2021 11:17:28 +0200
Johannes Brakensiek <ml@codingpastor.de> wrote:

Thanks. I've set up up that repository and I'm now happily using
ArcticFox. As an aside, I had also tried Konqueror - it has the same
problem as firefox. Epiphany did work but it was extremely slow, taking
minutes to load simple pages and the colors were all wrong.

Nice to know that the ArcticFox efforts are of use a lot of single-man effort is going into it. It will need mmore help, especially with people ore expert of gecko and firefox, but for now it churns along. The obsolete but also update browser. Recent news are import of more AltiVec/VMX code from TenFourFox and available for everybody! But I don't think the PowerProgressCommunity package is recent enough.

I've had a closer look into the poor performing graphics and it
seems this the norm. "Forcing AGP to PCI mode" seems to have
always been the default for many years on powerpc:
and so it's simply a case of poorly drivers. I tried installing the non-
free amd firmware (firmware-amd-graphics) but it made no difference.
Trying to enable glamor or DRI3 resulted in Xorg crashing. When using
fbdev I get only 100FPS in glxgears, compared to close to 1000 with
radeon, but everything else is very slow with radeon so it's not
otherwise usable. Ultimately I don't think being forced to use fbdev
really matters, these old GPUs have nothing to offer beyond 3D
acceleration - which has little application on this system in 2021. It
would however be interesting to see if this radeon slowness is
replicated on x86.

I don't know which applications do you use, but for me things are not as bad. I have both a PowerBook G4 and an iMac G5 now running Debian with both ATI Radeon and things are quite nice. Moving windows along, scrolling in most application is quite acceptable. I use GNUstep (obviously) and GWorkspace, Ink, Graphos run quite well, no noticeable lag. Xterm is blazingly fast, Terminal.app is less, but that's the code, still usable though. So something is not working at your place.

Radeon drivers are still decent (maybe the only ones along with Intel) on Intel.

I do have some more serious issues with WebGL on PowerPC with Radeon. O test using ArcticFox

- on the iMac G5 some of the examples show completely wrong textures and absurd colors

- on the PowerBook G4 similar issues, but not the same artifacts

- on the iBook G4 (still with Radeon and very similar to the PowerBook G4) WebGl fails to initialize.

Graphics is accelerated, so with wrong textures but one can see that it is working!

All systems have AMD firmware installed, I don't understand the iBook issue.

So on your system, which is better than mines, things must be more than usable!


Reply to: