[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Some questions, plus hfsprogs is missing

On Sun, 25 Apr 2021 11:17:28 +0200
Johannes Brakensiek <ml@codingpastor.de> wrote:

> I don’t know about the other issues, but there is a known issue about 
> Firefox and Thunderbird[1] which was fixed by Adrian and should be 
> delivered by sid soon.
> As long you might want to use ArcticFox from Riccardo Mottola which
> you can retrieve using the powerprogess repo like so (from root, if
> you have sudo installed):

Thanks. I've set up up that repository and I'm now happily using
ArcticFox. As an aside, I had also tried Konqueror - it has the same
problem as firefox. Epiphany did work but it was extremely slow, taking
minutes to load simple pages and the colors were all wrong.

I've had a closer look into the poor performing graphics and it
seems this the norm. "Forcing AGP to PCI mode" seems to have
always been the default for many years on powerpc: 
and so it's simply a case of poorly drivers. I tried installing the non-
free amd firmware (firmware-amd-graphics) but it made no difference.
Trying to enable glamor or DRI3 resulted in Xorg crashing. When using
fbdev I get only 100FPS in glxgears, compared to close to 1000 with
radeon, but everything else is very slow with radeon so it's not
otherwise usable. Ultimately I don't think being forced to use fbdev
really matters, these old GPUs have nothing to offer beyond 3D
acceleration - which has little application on this system in 2021. It
would however be interesting to see if this radeon slowness is
replicated on x86.

I've also now created a new problem for myself. My system has two disks,
one with MacOS and now one with Debian. I had disconnected the MacOS
disk while I installed Debian. After completing the installation, the G5
would boot into Debian only if the Mac disk was unplugged. My mistake
was to then go into the startup disk utility on MacOS and see if I
could make Debian the startup disk. This didn't work and with the Mac
disk unplugged I now get the flashing "?" folder (I can still boot
manually from OpenFirmware). I guess MacOS has erased an nvram variable
set by the Debian installer? Is there an easy way to reproduce what the
installer did and get Debian booting automatically again?


Reply to: