[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Xorg non starting (was : Re: Updated installation images for Debian Ports 2019-11-22)


On 12/24/19 2:04 PM, Bertrand Dekoninck wrote:
> I’ve installed firmware-linux-nonfree_0.43 from Jessie

You can just add the following line to your /etc/apt/sources.list:

deb [arch=all] http://ftp.de.debian.org/debian unstable contrib non-free

and then just install the firmware using apt. I wouldn't recommend using
outdated firmware packages from Jessie unless they contain firmware not
available in the newer package versions.

> and now I’ve got X11 running with 3d (some colors are flipped as usual in Kodi on ppc).
> Is the firmware-ams-graphics broken in sid ? Overall, Mate is a lot more sluggish on this
> G5 than with Jessie on my Powerbook G4.

I thought you installed the firmware package from Jessie?

> It shouldn’t. At least firefox works here more reliably on the G5. I’ll try later
> an install of GNUstep+Windowmaker, which I find lighter than Mate.

I'm confused: First you said, Mate is sluggish on sid, then you say Firefox runs
well on the G5.

Please clarify what is running where.

> Also, Is there a way to boot osX with grub now ?

I have not looked at this at all yet. I have to work on ofpathname first which
will hopefully happen within the next days.

I'm sorry for the slow progress, but at the moment there isn't really anyone helping
me with these tasks, so progress can only happen when I find the time for it.

>  I've got a triple boot install : sid (with grub on /dev/sda2), osX and wheezy
> (with yaboot on /dev/sdb2). But I can't boot sid with yaboot

Well, yes, because Yaboot cannot handle modern ext4 partitions. That's why I recommend
to refrain from using Yaboot for new installations.

> and I can't boot osX with grub. I can't mount my sid ext4 partition in wheezy either.

The ext4 partition is most likely using modern 64-bit features not supported by the
Wheezy kernel.

> Are there some new options to the ext4 filesystem enabled in sid that aren't available
> in wheezy.

There are. Not sure though whether this would completely block mounting the filesystem
from an older kernel.

> Can yaboot access to the kernel on the sid partition ?

No. Yaboot cannot deal with a partition with a modern ext4 filesystem. You need to use
ext2 for the kernel and initrd when you want to boot with Yaboot.

> The grub partition doesn't appear in the apple openfirmware boot screen (the one you
> can access  pressing the alt key at startup). Is there a way to have it there ?

Yes. I have to work on ofpathname to make this happen, see:

> https://github.com/ibm-power-utilities/powerpc-utils/issues/30

> No progress on this. 

Well, because I haven't worked on it yet and noone else so far has been willing
to step up adding support for PowerMac OF paths to the ofpathname script.
> I also encountered two sudden power off of the machine.

No idea what could have happened here.

> Strange, and the grub partition is now mounted read-only because of the crash.

I guess you need to run an fsck on it.

> I’ve tried to check the hfs filesystem but it fails.

How did you do that?

> I’ve used the rescue mode of the install media to restore it. But is it the only> way to proceed ? What is the correct way to restore it ? Unmount, then format it
> as hfs, reinstall grub with grub-install ? I’m not very familiar with grub.

You can't really use GRUB at the moment until I have fixed ofpathname unless you
want to install GRUB completely manually [1].


> [1] https://github.com/ibm-power-utilities/powerpc-utils/issues/30

 .''`.  John Paul Adrian Glaubitz
: :' :  Debian Developer - glaubitz@debian.org
`. `'   Freie Universitaet Berlin - glaubitz@physik.fu-berlin.de
  `-    GPG: 62FF 8A75 84E0 2956 9546  0006 7426 3B37 F5B5 F913

Reply to: