[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Xorg non starting (was : Re: Updated installation images for Debian Ports 2019-11-22)

More progress again
> Le 23 déc. 2019 à 12:14, Bertrand Dekoninck <bertrand.dekoninck@gmail.com> a écrit :
>> • Last : X fails to load. At the end of the boot, the system left me with a big black screen and a little « —« cursor at the top left of the screen. display-manager.service failed, living me with an unusable console and I couldn’t with to another VT.
>> From ssh on another machine,I’ve tracked the failing service (lightdm), run Xorg -configure and tried to launch it with the created config file. I finally could see error messages on my screen and now I can log in. Here is the message I’ve got  when launching X with the created xorg.conf
I’ve installed firmware-linux-nonfree_0.43 from Jessie and now I’ve got X11 running with 3d (some colors are flipped as usual in Kodi on ppc). Is the firmware-ams-graphics broken in sid ? Overall, Mate is a lot more sluggish on this G5 than with Jessie on my Powerbook G4. It shouldn’t. At least firefox works here more reliably on the G5. I’ll try later an install of GNUstep+Windowmaker, which I find lighter than Mate.

> Also, Is there a way to boot osX with grub now ?
>  I've got a triple boot install : sid (with grub on /dev/sda2), osX and wheezy (with yaboot on /dev/sdb2). But I can't boot sid with yaboot and I can't boot osX with grub. I can't mount my sid ext4 partition in wheezy either. Are there some new options to the ext4 filesystem enabled in sid that aren't available in wheezy. Can yaboot access to the kernel on the sid partition ? .
> The grub partition doesn't appear in the apple openfirmware boot screen (the one you can access  pressing the alt key at startup). Is there a way to have it there ?

No progress on this. 

I also encountered two sudden power off of the machine. Strange, and the grub partition is now mounted read-only because of the crash. I’ve tried to check the hfs filesystem but it fails. I’ve used the rescue mode of the install media to restore it. But is it the only way to proceed ? What is the correct way to restore it ? Unmount, then format it as hfs, reinstall grub with grub-install ? I’m not very familiar with grub.


Reply to: