[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trying 2019-04-06 image

On 4/7/19 13:47, aggaz wrote:
Il 07/04/19 13:24, Frank Scheiner ha scritto:
Nice, that the boot from USB stick worked for you. What type of G5 are
you using "7,2", "7,3", "9,1" or "11,2"? See [1] for details about the
different models.

Considering that I have 2 ethernet ports, I suppose I have a PowerMac11,2.

I think so, too.

And could you please also provide the output of
`devalias` from OpenFirmware for reference, as I'm unsure if the "ud"
alias is always predefined?

Is there a way to save the standard output from OpenFirmware to a text
file? If so, I would paste here the output.

Ah sorry, I forgot that there's usually no serial console port available
on G5s. I have one installed in my flaky 7,3 but I believe for 11,2 type
G5 such console ports were never made available.

There is the possibility to start a telnet server from within OF and
then telnet into it from another host (see [1] for details).


But maybe this is too much of an effort. A picture will do just fine, too.

If there is not a way I can send a picture. Is sending a picture to the
mailing list appropriate/permitted?

You can also just send a link to a picture on an image hoster for example.

I created a new "mac" partition on the hard drive. I tried manual
partitioning but was not able to find a way to create a new "bootstrap"
I remember there was an option for it in the past, now I can not find
this option for a new partition anymore.

Interesting, I can't remember if I explicitly tested manual
partitioning. I'll have a look into this. It could be that maybe the
naming has changed sometime in the past. For the NewWorld/HFS bootstrap
partition you need to use the newworld method or type (provided by

After re-reading what I wrote, I noticed that here I meant "I created a
new "mac" partition *table*" and not "a new "mac" partition". Sorry.

No need for, I understood you correctly.

Anyway, I remember manually partitioning my hard drive in the past and I
always found a way to create a newworld "bootstrap" partition. Now I
could not find any.

I now checked the manual partitioning on disk with the first 512 MiB
wiped and indeed something is missing:

┌───────┤ [!!] Partition disks ├───────┐
│                                      │
│ How to use this partition:           │
│                                      │
│  Ext4 journaling file system         │
│  Ext3 journaling file system         │
│  Ext2 file system                    │
│  btrfs journaling file system        │
│  JFS journaling file system          │
│  XFS journaling file system          │
│  FAT16 file system                   │
│  FAT32 file system                   │
│  swap area                           │
│  physical volume for encryption      │
│  physical volume for RAID            │
│  physical volume for LVM             │
│  physical volume for ZFS             │
│  do not use the partition            │
│                                      │
│     <Go Back>                        │
│                                      │
...there's no option for "NewWorld [...]" (all available options are
shown!). Checking the ISO image I couldn't find a partman-newworld UDEB
on it. So that seems to be missing.

It also does not exist on ftp.ports.d.o, neither for ppc64 nor for
powerpc. I know it got lost for powerpc but I assumed it was still there
for ppc64. Can we just reuse an older package from snapshots.d.o?

What's interesting is, that I could finish the installation with
automatic partitioning after inserting the missing script for
d-i/grub-installer without an issue yesterday and the result was
bootable. The first 512 MiB of the disk were wiped prior to the
partitioning (just like today), so nothing (neither data from the
original HFS bootstrap partition nor disk layout) from an older
installation could have remained and it still worked without
partman-newworld in place.

So it looks like partman-newworld is then only really needed to support
manual partitioning.

So I used automatic partitioning of the whole drive, which gave me this

SCSI4 (0,0,0) (sdc) - 163.9 GB ATA Maxtor 6L160M0
#1     32.3 kB                    Apple
#2     20.0 MB  B  K              untitled
#3    160.4 GB     f  ext4        untitled      /
#4      3.6 GB     f  swap        swap          swap
         512.0 B        FREE SPACE

I felt like something was missing but I continued the installation

No, actually that's fine this way. The first partition contains the
partitioning layout - IIC - the second is the NewWorld/HFS bootstrap
partition (which will only later be mounted at `/boot/grub`, because
"d-i/partman-newworld" can't format or mount that, it just makes sure a
partition is created), a separate partition for `/boot` is not needed,
so everything can reside on the root FS.

Glad to know that the partition layout was fine. Still it seems strange
to me that the second (20M) partition does not appear to be formatted in
any way. It should appear formatted as HFS, right?

Actually that was never implemented in partman-newworld but in the past
done by d-i/yaboot-installer and now by d-i/grub-installer with the
`mkhfs-bootstrap.sh` script. partman-newworld implements just so much to
create a partition with partman and to make sure that yaboot-installer -
or `mkhfs-bootstrap.sh` nowadays - could/can identify the correct
partition and handle it.


Reply to: