[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trying 2019-04-06 image

Il 07/04/19 13:24, Frank Scheiner ha scritto:
> Nice, that the boot from USB stick worked for you. What type of G5 are
> you using "7,2", "7,3", "9,1" or "11,2"? See [1] for details about the
> different models.

Considering that I have 2 ethernet ports, I suppose I have a PowerMac11,2.

> And could you please also provide the output of
> `devalias` from OpenFirmware for reference, as I'm unsure if the "ud"
> alias is always predefined?

Is there a way to save the standard output from OpenFirmware to a text
file? If so, I would paste here the output.
If there is not a way I can send a picture. Is sending a picture to the
mailing list appropriate/permitted?

>> I created a new "mac" partition on the hard drive. I tried manual
>> partitioning but was not able to find a way to create a new "bootstrap"
>> partition.
>> I remember there was an option for it in the past, now I can not find
>> this option for a new partition anymore.
> Interesting, I can't remember if I explicitly tested manual
> partitioning. I'll have a look into this. It could be that maybe the
> naming has changed sometime in the past. For the NewWorld/HFS bootstrap
> partition you need to use the newworld method or type (provided by
> partman-newworld).

After re-reading what I wrote, I noticed that here I meant "I created a
new "mac" partition *table*" and not "a new "mac" partition". Sorry.
Anyway, I remember manually partitioning my hard drive in the past and I
always found a way to create a newworld "bootstrap" partition. Now I
could not find any.

>> So I used automatic partitioning of the whole drive, which gave me this
>> layout:
>> SCSI4 (0,0,0) (sdc) - 163.9 GB ATA Maxtor 6L160M0
>> #1     32.3 kB                    Apple
>> #2     20.0 MB  B  K              untitled
>> #3    160.4 GB     f  ext4        untitled      /
>> #4      3.6 GB     f  swap        swap          swap
>>         512.0 B        FREE SPACE
>> I felt like something was missing but I continued the installation
>> anyway.
> No, actually that's fine this way. The first partition contains the
> partitioning layout - IIC - the second is the NewWorld/HFS bootstrap
> partition (which will only later be mounted at `/boot/grub`, because
> "d-i/partman-newworld" can't format or mount that, it just makes sure a
> partition is created), a separate partition for `/boot` is not needed,
> so everything can reside on the root FS.

Glad to know that the partition layout was fine. Still it seems strange
to me that the second (20M) partition does not appear to be formatted in
any way. It should appear formatted as HFS, right?

>> Grub installation failed with the following message:
>> "An installation step failed. You can try to run the failing item again
>> from the menu, or skip it and choose something else. The failing step
>> is: Install the GRUB boot loader on a hard disk"
>> On the log screen I see:
>> Apr  7 08:05:14 main-menu[4663]: (process:25067): dpkg-divert: warning:
>> diverting file '/sbin/start-stop-daemon' from an Essential package with
>> rename is dangerous, use --no-rename
>> Apr  7 08:05:14 main-menu[4663]: (process:25067): dpkg-divert: warning:
>> diverting file '/sbin/start-stop-daemon' from an Essential package with
>> rename is dangerous, use --no-rename
>> Apr  7 08:05:14 main-menu[4663]: (process:25067):
>> /usr/bin/grub-installer:
>> Apr  7 08:05:14 main-menu[4663]: (process:25067): line 252:
>> Apr  7 08:05:14 main-menu[4663]: (process:25067):
>> /usr/lib/grub-installer/mkhfs-bootstrap.sh: not found
>> Apr  7 08:05:14 main-menu[4663]: (process:25067):
>> Apr  7 08:05:14 main-menu[4663]: WARNING **: Configuring
>> 'grub-installer' failed with error code 1
>> Apr  7 08:05:14 main-menu[4663]: WARNING **: Menu item 'grub-installer'
>> failed.
> See he lower part of [2] for an explanation. Unfortunately I forgot to
> add the newly created script (`mkhfs-bootstrap.sh`) to the list of files
> to be installed. So it was missing in the d-i/grub-installer udeb and
> not installed.
> [2]: https://lists.debian.org/debian-powerpc/2019/04/msg00067.html

Good to know that this issue is already taken care of. If I find time I
will try to manually add the script. Or I will try the next corrected
image when it comes.

>> Hope this report helps.
> Absolutely, this was a fine report.

Glad to be part of this collective effort.


Reply to: