[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: What's the status of hfsprogs?

On 11/22/18 01:19, Matti Palmström wrote:
    Can't say that I ever recognized your described behaviour on real
    hardware (G4 and G5). Mounting and unmounting so far always worked as
    long as the FS wasn't tempered with.

    Can you please also give some more details about used OS release and
    package version?

Virtualbox 5.2.22
Buster alpha3 amd64 (just to see if a thing works at all)

Ok, you're using it on a - let's say - "non-native" architecture, that could explain something.

hfsprogs 332.25-11+b2

Weird, now it works.

And it seems like I got my answer, grub can't boot from a HFS partition :-P

Maybe not on amd64, but GRUB **boots** from HFS on NewWorld PowerMacs (G4 and G5 and IIRC also tested successfully on G3 Blue & White).

Anyhow, from what you described earlier I assume it's more like the used x86 firmware provided by VirtualBox can't load GRUB from a HFS partition, which is pretty much expected. GRUB itself has ro support for a lot of file systems (check for example [1]).


[1]: http://git.savannah.gnu.org/cgit/grub.git/tree/grub-core/fs

Reply to: