[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: What's the status of hfsprogs?

On Wed, Nov 21, 2018 at 10:12 PM Frank Scheiner <frank.scheiner@web.de> wrote:

On 11/21/18 21:36, Matti Palmström wrote:
> Heya
> I'm toying around a bit with hfsprogs in a virtual machine and I wonder
> if anyone else has any experience with it? Is it terribly buggy or is it
> just me having bad luck?
> Mounting a HFS partition and writing to it seems to work alright but
> when I try to unmount the partition it hangs. I've also tried to sync
> the disk cache before I unmount it but it also hangs. Or locks.

Can't say that I ever recognized your described behaviour on real
hardware (G4 and G5). Mounting and unmounting so far always worked as
long as the FS wasn't tempered with.

Can you please also give some more details about used OS release and
package version?
Virtualbox 5.2.22
Buster alpha3 amd64 (just to see if a thing works at all)
hfsprogs 332.25-11+b2

Weird, now it works.

And it seems like I got my answer, grub can't boot from a HFS partition :-P


Reply to: