[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: jessie powermac yboot: ybin fails [solved]

On 03/07/2018 08:40 PM, Frank Scheiner wrote:
>> 1.3.16 on Jessie. I've never discovered any indication anything newer than
>> Jessie was available for a G4. If I s/jessie/stretch/g sources.list, I get 5
>> errors from apt-get update for failing to find index files.
> IIC, powerpc is only existing in Sid currently.

It is. The only change that happened with powerpc after Jessie was released is
that it the release team disabled the testing migration and hence effectively
ignored it for the next stable release.

Everything else remained unchanged. Packages for powerpc are still built as they
were before. Please note that normally all new packages for any architecture
are built on unstable first. The packages built in unstable just propagate
into testing after a given period of time.

You can continue to use Debian on powerpc as before. You just don't get to have
a stable release at the moment but you must track unstable. However, we are
planning to eventually support Debian testing in Debian Ports. This involves
setting up an instance of a software called Britney which is what is responsible
for migrating packages from unstable to testing.

>> Simply removing the macosx=/dev/hda10 line from yaboot.conf solved the problem.
>> Ybin simply runs with no visible output. :-D
> So either the double usage of the macosx stanza or the non-existing device is the problem.

The main problem here is that we still haven't migrated from Yaboot to GRUB
on PowerPC Macintoshes :(.


 .''`.  John Paul Adrian Glaubitz
: :' :  Debian Developer - glaubitz@debian.org
`. `'   Freie Universitaet Berlin - glaubitz@physik.fu-berlin.de
  `-    GPG: 62FF 8A75 84E0 2956 9546  0006 7426 3B37 F5B5 F913

Reply to: