[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: jessie powermac yboot: ybin fails [solved]

On 03/05/2018 01:34 AM, Felix Miata wrote:
what Debian release are you actually running and what yaboot version
(shown above yaboot boot prompt) have you installed? I'm running Sid
(just upgraded all packages minutes ago) and yaboot 1.3.17.

1.3.16 on Jessie. I've never discovered any indication anything newer than
Jessie was available for a G4. If I s/jessie/stretch/g sources.list, I get 5
errors from apt-get update for failing to find index files.

IIC, powerpc is only existing in Sid currently.

On 03/02/2018 04:51 PM, Felix Miata wrote:

# ybin
ofpath: Device: /dev/ata-ST is not supported
ybin: Unable to determine OpenFirmware path for macosx=/dev/disk/by-id/ata-ST340015A_5LA13M03-part10 macosx=/dev/hda10
ybin: Try specifying the real OpenFirmware path for macosx=/dev/disk/by-id/ata-ST340015A_5LA13M03-part10 macosx=/dev/hda10 in /etc/yaboot.conf

It looks like you have the "macosx=" option twice in your `yaboot.conf`
on top and at the bottom. I'm unsure if this is an issue though. Does
someone with Debian and Mac OS X on their machine know more?

But does `/dev/hda10` really exist on your machine?

I remember only having trouble finding helpful docs on trying to customize
yaboot.conf. It might have been a pre-sata doc I was working from. sda1-14
exist, but no hda*, and fdisk finds neither, hence my use of parted. Still I'd
like to know something that can distinguish or explain sda2-7.

Simply removing the macosx=/dev/hda10 line from yaboot.conf solved the problem.
Ybin simply runs with no visible output. :-D

So either the double usage of the macosx stanza or the non-existing device is the problem.

Reply to: