[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Aw: Re: G4 MacMini network boot of install media failing at system clock set

Thanks to those who responded. 
boot usb1/disk:,\install\yaboot
gets me a
Warning: Sector Size Mismatch! can't OPEN boot usb1/disk:,\install\yaboot
message, which is what has happened before.  
I did get further with the installer from the network boot! It got up to 'detecting hardware please wait' and then stopped at 0%. 
I thought this was because I had put  
append="radeon.agpmode=-1 modprobe.blacklist=ams"
as suggested here: https://wiki.debian.org/PowerPC/FAQ#How_do_I_get_graphics_working.3F
in yaboot.conf, but I tried it a second time and got the old behaviour of stopping at rtc-generic.
That's quite mysterious.  The only thing I can think of is that OF seemed to hang when i tried accessing one of the USB devices, and this managed to boot immediately afterwards.  Maybe that reset something? 
I don't have a firewire CD-ROM. 
I do however have a firewire hard-drive enclosure somewhere.  What would I need to do to boot off that?  Make an HFS partition or something? 
If your G4 mini is having trouble with the internal hard-drive, you might try installing to an external FireWire hard drive. Booting from FireWire is a supported feature of the NewWorld Mac OpenFirmware. While booting from USB is possible with some models, it’s not as well supported.

My G4 minis (I have 3) all have, at one time or another, booted from a FireWire external. But YMMV, of course.

Also, if you suspect the problem is with the internal HD itself (i.e. not a problem with the motherboard), it’s not too difficult to replace it with an SSD, which would make the G4 mini a bit more responsive.

Good luck on getting it running. They are great little machines!


On Apr 26, 2016, at 9:04 AM, Milan Kupcevic <milan@debian.org> wrote:

> On 04/26/2016 05:53 AM, arc@vorsicht-bissig.de wrote:
>> Hi folks,
>> I have been trying to resurrect my MacMini.
> Is your internal CD/DVD broken?
> People had success installing from an external firewire CD/DVD drive
> and/or from a memory stick containing raw debian installer iso as is
> described in this message:
> https://lists.debian.org/debian-powerpc/2012/08/msg00041.html
> You could also try to connect an external USB CD/DVD drive and try to
> boot the machine using the same commands as is instructed for raw iso
> memory stick in the mentioned message.
> Let us know if this works for you with current Debian install media.
> Milan

Reply to: