[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian on iMac G5



Use a 'powerpc' or 'powerpc64' (aka ppc64) installer for your case. Do
NOT use powerpc64el this wont work for your arch.

-M

On Thu, Mar 17, 2016 at 2:59 PM, Steven Grunza <steven.grunza@gmail.com> wrote:
> I wouldn't mind trying stretch.  Should I use the powerpc or the ppc64el
> image?  From what I've been able to figure out the powerpc image seems to
> contain both 32-bit and 64-bit code and the ppc64el is for a different type
> of machine than I have.  My machine is an old multi-hand-me-down iMac G5.
>
> My plan for tonight (timezone is EST5EDT) is to try downloading and
> installing from debian-stretch-DI-alpha5-powerpc-netinst.iso
>
>
> On Thu, Mar 17, 2016 at 4:15 AM, Clive Menzies <clive@clivemenzies.co.uk>
> wrote:
>>
>> On 17/03/16 08:10, Mathieu Malaterre wrote:
>>>
>>> On Thu, Mar 17, 2016 at 9:08 AM, Clive Menzies <clive@clivemenzies.co.uk>
>>> wrote:
>>>>
>>>> On 17/03/16 00:25, Steven Grunza wrote:
>>>>>
>>>>> Should I expect Debian debian-8.3.0-powerpc-xfce-CD-1 to work on an
>>>>> Apple
>>>>> iMac G5?
>>>>>
>>>>>
>>>>> I tried installing it and just have a blank screen.
>>>>>
>>>>> Using Control-Option-F1 I have a text console on the built-in display
>>>>> that
>>>>> is displaying
>>>>>
>>>>>
>>>>> [ looks like a timestamp ] nouveau E[    DRM] DDC responded, but no
>>>>> EDID
>>>>> for TV-1
>>>>>
>>>>> I'm getting these about one every 10 seconds.
>>>>>
>>>>> Is there a different video driver I can try?  If so, how to I enable
>>>>> it?
>>>>>
>>>>> lspci reports a "VGA compatible controller: NVIDIA Corporation NV34M
>>>>> [GeForce FX Go5200]  (rev a1)
>>>>>
>>>>>
>>>> Hi Steven
>>>>
>>>> I've a different GeForce (6600) but Debian stretch (testing) with
>>>> 4.5.0-rc2-powerpc64 kernel works for me.
>>>>
>>>> You can get the kernel built by Peter Saidanas here:
>>>>
>>>> https://drive.google.com/folderview?id=0B8pqd5Ots1vfT2puX09CYjEwcFk&usp=drive_web
>>>
>>> OP did mention he was using 'powerpc' not ppc64 flavor.
>>>
>>> But I am curious is the official debian kernel 4.5.0-rc2-powerpc64 not
>>> working for you ? What's so special about the one from 'Peter
>>> Saidanas' ?
>>
>> Hi Mathieu
>>
>> I wasn't aware there is an official debian 4.5.0-rc2 available but confess
>> I didn't look when I was trying to get my G5 up and running. If I have time,
>> I'll try the official kernel to see if it works here.
>>
>> Regards
>>
>> Clive
>>
>


Reply to: