[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Blank screen on Powermac

Original message from Alberto Mi, 2015-10-18 08:41:
> Hello, have reintalled Debian on my powermac G4 for update to Jessie and
> after the boot command I just get a complete blank screen that doesn't me
> allow to do nothing.
> I have a 6200 AGP nvidia working great before with Linux and osX.
> I already tried the command *noveau.nouaccel=1* during the boot phase, but
> seems not to work.
> Anyone with this issue? Thanks a lot.
> powermi [at] gmail [dot] com


I have the same graphics card. It works for me on Debian testing with
the following work-around:

I used a PC-VBIOS from https://www.techpowerup.com/vgabios/ and saved it
as /lib/firmware/geforce_6200.fw. I added the following line to the
kernel command line in GRUB and yaboot:

You may choose the card closest to your card (the same manufacturer).
Assuming you have a 256MB VRAM version:

If one VGA-BIOS-ROM does not do the job, try another one.

Note that you will need to ssh into the machine to do this, or access
the yaboot and grub configuration files from the installation media in
rescue mode, or install an older version of Debian Linux that uses a
kernel pre-4.0, do the configuration and then update to a newer version.

I am not 100% sure, but I think that Debian 7.5 worked well. Maybe 7.7
still does too. Debian 8.0 already has this issue and cannot be used
without work-around.

If you need more information, just ask.
Good luck!

Reply to: