[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian 8 on Late 2005 G5, Graphics Issues

Hi Rick,
You have a 64Kb pagesize kernel. Don't waste your time trying to get nouveau working on it for now.
You need a 4Kb pagesize kernel.

Also, I bet with a newer kernel, i.e. what you seem to be using, the nouveau module will fail to load as it cannot find the DCB block. I would be curious to see your dmesg log as well.
You can force nouveau to load a bios from a file, I used an x86 bios just so it can extract a DCB block... but lets not complicate things for now.

For starters, To me it looks like the nouveau driver has not been loaded. What kernel options have you got appended on yaboot?

You would be better off not appending any options to yaboot.conf and blacklisting nouveau for now.

Ill look into making a 4Kb pagesize kernel as a deb package. The 4.0+ version kernels require extra mucking around (for the DCB issues)...

Is a kernel from the 3.18 series ok? Where can I upload a deb package?


On Mon, Jun 29, 2015 at 4:31 PM, Rick Thomas <rbthomas@pobox.com> wrote:
Wow!  Thanks Peter!

I’d pretty much given up on getting nouveau graphics working on my G5 (I plan on using it as a headless server anyway, so graphics is not on the critical path).

This gives hope.

Here’s the data on my machine…

> root@bigal:~# getconf PAGESIZE
> 65536

> root@bigal:~# cat /proc/interrupts
>            CPU0       CPU1
>  16:     324536      15894   MPIC 1      0 Level     keywest i2c
>  18:        764     102621   MPIC 1     10 Level     0001:03:0c.0
>  25:        159     375469  MPIC-U3MSI   8 Edge      eth0
>  27:          1          4   MPIC 1     27 Level     keywest i2c
>  38:      29521      89263   MPIC 1     38 Level     0001:03:0d.0
>  39:         11         12   MPIC 1     39 Level     firewire_ohci
>  48:          0          0   MPIC 1     48 Edge      SMU message
>  53:    1621617     666640   MPIC 1     53 Edge      SMU doorbell
>  63:         10         27   MPIC 1     63 Level     ehci_hcd:usb1, ohci_hcd:usb3, ohci_hcd:usb4
>  70:        113        148   MPIC 1     70 Level     ehci_hcd:usb2, ohci_hcd:usb5, ohci_hcd:usb6
> 251:      13836        368   MPIC 1    251 Edge      ipi call function
> 252:     122217     108015   MPIC 1    252 Edge      ipi reschedule
> 253:          0          0   MPIC 1    253 Edge      ipi tick-broadcast
> 254:          0          0   MPIC 1    254 Edge      ipi debugger
> LOC:    1186599    1736402   Local timer interrupts for timer event device
> LOC:        259        130   Local timer interrupts for others
> SPU:         78         46   Spurious interrupts
> PMI:          0          0   Performance monitoring interrupts
> MCE:          0          0   Machine check exceptions
> HMI:          0          0   Hypervisor Maintenance Interrupts

> root@bigal:~# lspci | grep -i vga
> 0000:0b:00.0 VGA compatible controller: NVIDIA Corporation NV43 [GeForce 6600 LE] (rev a2)

> root@bigal:~# uname -a
> Linux bigal 4.0.0-2-powerpc64 #1 SMP Debian 4.0.5-1 (2015-06-16) ppc64 GNU/Linux

Interpreting the “/proc/interrupts” data is not obvious to me.  Can you help?


PS: Do you have a ‘.deb’ for your re-compiled kernel?  Or could you point me to a good description of what I would do to compile one of my own?   Thanks in advance!

On Jun 28, 2015, at 10:48 PM, Peter Saisanas <psaisanas@gmail.com> wrote:

> Hi,
> I also have a Powermac G5 Quad and tried with both the Geforce 6600 and Quadro FX4500 video cards and I have successfully gotten it up and running using the nouveau driver along with 2D acceleration on the XOrg desktop. I have compiled many newer kernels and created debian packages for them. Newer 4.0+ kernels also have issues in terms of detecting the nvidia DCB from the FCODE ROM… But there are other workarounds for this to get it up and running. You shouldn't need to use the boot parameter "nouveau.noaccel=1" once you have properly configured your kernel.
> In my case, the reason why X does not seem to work with your configuration is twofold:
> The recent Debian (and Fedora) kernels for PowerPC 64 Bit running on the G5 64bit powermac are configured with a 64Kb kernel pagesize. This works slightly better in terms of performance, however the nouveau driver does not support this size. You must recompile the kernel unfortunately and configure with 4Kb kernel pagesize as this is what nouveau will work with for now.
> To confirm, run the following command in a shell as root:
> “getconf PAGESIZE”
> If it returns 65536, you are using a 64Kb pagesize kernel.
> Otherwise if it returns 4096, i.e. 4Kb kernel pagesize, check the next item below.
> The newer nouveau drivers in more recent kernels default to using MSI interrupts, however with the PPC G5, when using  MSI interrupts, the powerpc FCODE rom on Nvidia cards does not correctly set up the MSI address (or vector).
> To confirm, run the following command in a shell as root:
> “cat /proc/interrupts”
> Look for the nouveau interrupt, if it is using MSI interrupts, you need to disable MSI interrupts either by passing the option to the nouveau module, disable MSI interrupts by passing an option to the kernel command line in yaboot.conf or disable MSI interrupt support in total when compiling a new kernel. If configured correctly, nouveau should be using level or edge interrupts.
> This is what worked for me anyway.
> Cheers,
> Peter

Reply to: