[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems with X11 on Ultra10

I was curious as to what prompted you to try "SBUS:/SUNW,ffb@1e,0" for the BusID value?

-----Original Message----- From: Sad Clouds
Sent: Sunday, May 04, 2014 3:57 AM
To: Hayden Kroepfl
Cc: debian-ports@lists.debian.org
Subject: Re: Problems with X11 on Ultra10

On Sun, 4 May 2014 08:25:16 +0100
Sad Clouds <cryintothebluesky@googlemail.com> wrote:

On Sat, 03 May 2014 17:20:33 -0600
Hayden Kroepfl <perlpowers@gmail.com> wrote:

> On 03/05/14 03:39 PM, Sad Clouds wrote:
> > Hello, I'm new to Debian and trying it out on Ultra10 which has
> > Creator3D framebuffer.
> >
> > I installed Debian stable and seem to be having some issues with
> > X11 or display manager. The system boots OK and I can see boot
> > messages, but when it goes to start display manager the screen
> > goes black and nothing happens. No windows, no mouse cursor,
> > nothing.
> >
> > Any ideas?
> >
> >
> Might as well ask about the obvious right away, do you have your
> monitor hooked up to the onboard video in the bottom left corner
> (facing the back), or to the 13W3 video connector on the Creator3D?
> What could be happening is X11 picked the wrong card by default and
> is only showing it on the opposite connector. If you have a second
> monitor try hooking one up to the 13W3 and one to the VGA connector.
> Hayden K.

Hello, that was the first thing I tried however there is no VGA signal
on machfb. I managed to get IP address assigned to this machine from
DHCP server, logged in via ssh and looked at the logs. Looks like X
server has problems configuring framebuffer device.

So I generated xorg.conf manually with 'X -configure' and it thinks I
have 3 cards:

        Identifier  "Card0"
        Driver      "mach64"
        BusID       "PCI:1:2:0"

        Identifier  "Card1"
        Driver      "fbdev"
        BusID       "PCI:1:2:0"

        Identifier  "Card2"
        Driver      "vesa"
        BusID       "PCI:1:2:0"

This looks wrong to me, one of them should be using sunffb driver. And
why all three drivers refer to the same BusID?

I tried copying this file to /etc/X11/xorg.conf and leaving only

        Identifier  "Card1"
        Driver      "sunffb"
        BusID       "PCI:1:2:0"

But still can't get X11 running

Any ideas?

OK changed that to

BusID "SBUS:/SUNW,ffb@1e,0"

and X11 works now.

To UNSUBSCRIBE, email to debian-powerpc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org Archive: [🔎] 20140504085745.1a1891593485ab7e82a149a0@googlemail.com">https://lists.debian.org/[🔎] 20140504085745.1a1891593485ab7e82a149a0@googlemail.com

Reply to: