[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PowerPC install stuck at dmesg

gave it another try this evening, and for no apparent reason, it booted up to a much furthur place, still not an install, but past memory allocations.  It had a line that said ----cut here----
followed by a slew of messages, some of which began with 'kernel bug' and a memory dump.  I attempted to take a picture, but the machine had already reset by the time I had found a camera.  I am attempting to duplicate that result now.

On Thu, Aug 16, 2012 at 5:14 AM, Tek <tek@castyour.net> wrote:
I had similar issues with hanging on boot about a month ago with
powerpc and I believe that it ended up being a corrupted boot ram
image.  Would drop into a limited shell when it tried to switch to
mounting the root file systems and visually "hang".  Sounds somewhat
similar, but I cant tell from your description if its exactly the
issue.  In my case I wasn't able to switch to any other console, but I
could type around int he initramfs shell still after the boot "hang".

The mdadm driver (not used for booting on my machine) was corrupting
the initram regeneration.  Removing and supressing the reinstalltion of
the mdadm script part of initramfs regeneration allowed a clean
initramfs to be built which booted fine.

Might be one of these bugs or another similar

My system did not boot even though the root filesystem was not on an
raid volume.

This really may not be your issue, but the symptoms go in the same
direction, so I though I would bring it up.



On Thu 16 Aug 2012 12:27:21 AM CEST, Rick Thomas wrote:
> On Aug 15, 2012, at 2:46 PM, Michael Aldridge wrote:
>>> On Wed, Aug 15, 2012 at 4:37 PM, Rick Thomas <rbthomas@pobox.com>
>>> wrote:
>>>> On Aug 15, 2012, at 1:52 PM, Michael Aldridge wrote:
>>>> okay, I understand now; although, there is a slight problem with
>>>> doing that, I have no other linux machines handy with disk drives.
>>>> Is there a way of doing that from the mac terminal?
>>> If you just put the CD in the CD drive with MacOS-X running, it
>>> should mount it.
>>> In the terminal window type "df" it will show (among other things) a
>>> volume mounted on /Volumes/Debian...
>>> Type "cat /Volumes/Debian*/.disk/info" (without the quotes)
>>> Report what you see.
>>> Rick
>> Debian GNU/Linux 6.0.5 "Squeeze"- Official powerpc NETINST Binary - 1
>> 20120512-20:49
> OK.  That says you are using the official "stable/Squeeze" netinst
> iso, available from
> http://cdimage.debian.org/cdimage/release/6.0.5/powerpc/iso-cd/debian-6.0.5-powerpc-netinst.iso
> This is the current version that has (presumably) been used by lots of
> folks since it was released last May.  So it's unlikely that the
> problem is in the ISO itself.
> Have you checked that the CD is bit-for-bit the same as the iso?
> I haven't personally tried this, but there is a "help" topic in the
> MacOS-X disk utility called "Verifying files are copied correctly from
> a disk image" that seems to tell you how to use checksums to tell if a
> CD was burned properly.
> Rick

Reply to: