[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PowerPC install stuck at dmesg

okay, I understand now; although, there is a slight problem with doing that, I have no other linux machines handy with disk drives.  Is there a way of doing that from the mac terminal?

On Wed, Aug 15, 2012 at 3:43 PM, Rick Thomas <rbthomas@pobox.com> wrote:

On Aug 15, 2012, at 8:25 AM, Michael Aldridge wrote:

On Wed, Aug 15, 2012 at 2:06 AM, Rick Thomas <rbthomas@pobox.com> wrote:

Resent-From: debian-user@lists.debian.org
From: Michael Aldridge <aldridge.mac@gmail.com>
Date: August 14, 2012 6:05:29 PM PDT
To: debian-user@lists.debian.org
Subject: PowerPC install stuck at dmesg

After deciding that the official OS was becoming too slow for this aging hardware, and Apple PowerBook G4 FW800 (not sure about the FW800, it could be the one immediately following that model), I decided to install debian and then a WM such as LXDE, to better use the hardware.  I downloaded, burned, and verified the ppc netinst disk, and it does boot to a yaboot prompt. I then type 'install' and a white screen briefly flashes onto the screen.  Then I see the output of dmesg as the machine partially boots, it makes it up to locating/defining the vmalloc and ioremap memory addresses, but then it appears to halt.

I do not recieve any messages such as kernel panics, clock to NO Hz mode, or similar; if I leave the computer, it will remain in that state until I reboot it.  My assumption is that this is not a console, just a dmesg readout, but I cannot figure out what the keybinding is on the mac to get to any other consoles.  I should point out that the disk drive remains spun up, then spins down a few minutes later.  I know how to use the text installer, if only I could get to it.

What I have tried so far:
reset the SMU
reset the nvram
reset the entire non-volatile memory
use the video flag offered in yaboot
connect an external monitor --> yields a grey screen with what looks like an open firmware readout, defining memory ranges

Any help is greatly appreciated, it was suggested that I ask this issue on one of the IRC channels, but having never used those before, I figured I'd stick with the mailing list I knew.

Hi Michael,

First: try sending this to the "debian-powerpc" list.  You may get more answers there...

Second: I have a couple of G4 tower machines that work just fine, but unfortunately I don't have any powerbooks to try, so I can't be of direct help to you.  However, the answers to a few questions may make it easier to diagnose your problem.

1) What netinst image did you download?  Can you supply the URL and time/date of the .iso?  One way to get this: Mount the CD (on /mnt, for example) and look in the file /mnt/.disk/info.  It will give your enough to uniquely identify the version, time and date of creation of the .iso .

2) I doubt what you're seeing is just dmesg output.  Certainly, on my tower machines, it's the real console output -- at least up to the stage you are talking about as it hangs.

3) To switch virtual consoles, try various combinations of <fn> <alt> and the F# keys for #=[1..4] .  If that doesn't work, add the <ctl>, <shift> and <cmd/apple> keys into the mix in that order.

4) Try an external USB keyboard.

Hope this helps!


The iso was downloaded from the debian.org mirror (as near as I can tell at least), and it is the small cd image available by clicking on the power-pc link below the heading of small cds.  The iso was obtained and burned yesterday.

  I tried the key combinations you suggested, but none worked.  I also tried with an external keyboard, but that seemed as though it did not register keypresses.

any other ideas?

I need to know *exactly* which iso you downloaded and burned.  Please follow the instructions in part (1) of my reply.  With the data from the .../.disk/info file on the CD I can download the exact same iso and test it on one of my G4 tower machines.  That will let us know if it's specific to your laptop, or a generic problem with that particular iso.


Reply to: