[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installing nouveau hints?

2010/10/11 Michel Dänzer <daenzer@debian.org>
On Fre, 2010-10-08 at 17:08 -0700, Gnu Turd wrote:
> I installed squeeze on a PowerBook G4 and was unhappy with the
> performance of the nv driver trying to use Blender & for graphics in
> general.
> 0000:00:10.0 VGA compatible controller: nVidia Corporation NV34M
> [GeForce FX Go5200] (rev a1)
> I tried setting up a xorg.conf and using nouveau, but couldn't get to
> X.  So I "upgraded" to sid/development, but it is still using the
> kernel.  I gather that nouveau has been added to the kernel
> of 2.6.33 and up.

FWIW, a lot of DRM changes from newer kernels are backported to the
sid/squeeze 2.6.32.y kernels, don't know offhand if that includes
nouveau though.

> So I thought I'd try setting the machine up as a mixed system.  I added
> the sid repositories to my sources.list and made unstable the default
> release in a /etc/apt/apt.conf.  I attempted to install
> linux-headers-2.6.33-2-powerpc, which I gathered might support nouveau
> better, but got unmet dependency errors.  It there a way to force
> apt-get to install a kernel on the experimental repository?

Yes, but as the package above is only available in experimental, there
shouldn't be anything to force really... If you post the actual
dependency errors, we might be able to help solve them.

A little knowledge is a dangerous thing, Michael.  What I had tried was this:

root@debmac:~# apt-get install linux-image-2.6.33-2-powerpc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 linux-image-2.6.33-2-powerpc : Depends: linux-base (>= 2.6.33-1~experimental.5) but 2.6.32-24 is to be installed
                                Recommends: firmware-linux-free (>= 2.6.33) but 2.6.32-24 is to be installed
E: Broken packages

So that got me thinking, how to overcome the error.  I normally use stable, but I like backports and know how to use it, so since linux-base was holding me back I tried this:

    apt-get -t experimental install linux-image-2.6.33-2-powerpc linux-base

Unfortunately I did this via ssh from my lenny desktop machine and I saw a blue configuration screen and then my Lenny konsole crashed (almost unheard of).  Dpkg was locked so I killed it and tried again from a local konsole, but after a 'dpkg --configure -a' and attempt to do the process again I got:

root@debmac:~# apt-get -t experimental install linux-image-2.6.33-2-powerpc linux-base
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-base is already the newest version.
linux-base set to manually installed.
linux-image-2.6.33-2-powerpc is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 203 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
Setting up linux-image-2.6.33-2-powerpc (2.6.33-1~experimental.5) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing linux-image-2.6.33-2-powerpc (--configure):
 subprocess installed post-installation script returned error exit status 1
configured to not write apport reports
                                      Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

So I tried rebooting to kill whatever was locking config.dat.  Then I tried the command again, that led me to a blue "configuring kernel" screen, but the command completed.  I then realized that grub was replaced by yaboot on this architecture (which I know nothing about), but the install came back with 2.6.33-2-powerpc. 

Unfortunately, killing X and modifying my xorg.conf to include nouveau still wouldn't let me back to the GUI with a "startx" & rebooting didn't help:

Build Date: 20 September 2010  06:13:09PM
xorg-server 2:1.7.7-7 (Julien Cristau <jcristau@debian.org>)
Current version of pixman: 0.16.4
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Oct 11 13:19:21 2010
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) [drm] failed to open device
(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

giving up.
xinit:  No such file or directory (errno 2):  unable to connect to X server
xinit:  No such process (errno 3):  Server error.

Crap.  So much for that theory (that a newer kernel would enable me to run nouveau).  So I did a "apt-cache policy" on xserver-xorg-video-nouveau and got:

  Installed: 1:0.0.15+git20100329+7858345-4
  Candidate: 1:0.0.15+git20100329+7858345-4
  Version table:
     1:0.0.16+git20100825+390f1c8-1 0
          1 http://ftp.us.debian.org/debian/ experimental/main powerpc Packages
 *** 1:0.0.15+git20100329+7858345-4 0
        990 http://ftp.us.debian.org/debian/ sid/main powerpc Packages
        100 /var/lib/dpkg/status

I installed the experimental version of xserver-xorg-video-nouveau & rebooted, but to no avail. KDM wouldn't start. I seem to have the only version of xserver-xorg & xorg in the repositories.  In installed the 2.6.33 kernel sources & linux-headers-2.6.33-2-common, FWIW.

So I reverted to the NV driver. I guess I could try compiling my own kernel, but I'm not an advanced user, just a 'dumb-as-rocks' end user.

Reply to: