[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: no sound on powermac3,3 (powerbook g4 550) debian502 gnome


On Mon, Sep 14, 2009 at 7:08 PM, Benjamin Cama <benoar@free.fr> wrote:
> Hi,
> Le lundi 14 septembre 2009 à 23:00 +0200, Gaudenz Steinlin a écrit :
>> On Sun, Sep 13, 2009 at 10:27:01PM -0300, Rogério Brito wrote:
>> >
>> > So, for a distribution kernel, I guess that, once nobody complains
>> > about the problems, we can just standardize on snd-powermac (and
>> > have people have a working setup) and document the potential
>> > (perhaps nonexistent?) problem in the release notes for the arch.
>> No, please not! At least on my powerbook5,8 snd-aoa works way better
>> than snd-powerpc. And AFAIK this is true for all newer Powerbooks. It
>> may be that snd-powermac is the only option for some of the older Apple
>> powerpc based hardware. But please only enable it for devices that are
>> not supported by snd-aoa.
> Completely agree with that. snd-aoa was made for newer Macs AFAIK, and
> it works very well here. The one that cause problem here is a
> powermac3,3 which is an old model, and which is not supported by snd-aoa
> according to http://johannes.sipsolutions.net/Projects/snd-aoa
> I am CC'ing Johannes, he may help us solve that long standing problem.

In this case we ought try to find a way to "detect" those machines and
add support for hw-detect to properly queue the  require module based
on that.

Otavio Salvador                  O.S. Systems
E-mail: otavio@ossystems.com.br  http://www.ossystems.com.br
Mobile: +55 53 9981-7854         http://projetos.ossystems.com.br

Reply to: