[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian lenny installation on an ibook g4 keeps freezing

A hardware problem indeed. I found out that it was a problem with the gpu by applying pressure below the option key to the left of the track pad, which is right above the gpu. Searching through some forums and sites I found that it was a common problem that the solder joints beneath the gpu would separate from the board & cause crashes and other problems.

Apple had some logic board repair program, but that expired a few years ago.

I was able to install debian with a desktop environment (awesome!) with the applied pressure. Also, I found people who were able to successfully bake the logic board in order to reflow the solder & repairing the joints under the gpu.

Unfortunately, before I was able to even able to figure out how I would take the logic board out & think about prepare it for baking, the computer wouldn't start anymore. I had taken it into my livingroom to plug it into the router to test the internet connection. Pressing the power button does nothing. Nothing starts, spins, or lights up. Nothing is to be heard. I have tried battery only, power adapter only, and both.
I have tried holding the power button down for 15 seconds with both battery and adapter not in. Then re-inserting them and trying again. I have also tried a PMU reset by holding down shift+ctrl+option+power & waiting five seconds & then powering up. No thing.

The battery is fully charged, and the adapter is new. The adapter had been working up until this point as well, so I do not know if it would be an issue.

Somewhere in between shuting down and moving it downstairs something must have moved, cracked? Pretty stumped at this point. I don't think this computer has a 'PMU' battery, if such a thing exists to keep the system time, etc. Motherboard does not have any visible damage that I am aware of...

I suspect something on the motherboard before the DC plug board since the battery is fully charged & yet nothing happens.


Thanks to everyone for the help.

2009/6/22 Michel Dänzer <daenzer@debian.org>
On Fri, 2009-06-19 at 22:23 -0400, Tomislav V. Butkovic wrote:
> I had someone try to boot OS X tiger via firewire drive which also
> froze at the 'apple' screen with a little counter that just keeps
> spinning.

That it happens with OS X as well indicates a hardware problem I'm
afraid. You could try to verify this with the hardware test CD that came
with the machine.

Earthling Michel Dänzer           |                http://www.vmware.com
Libre software enthusiast         |          Debian, X and DRI developer

-tomislav v. butkovic

Reply to: