[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sound not working on PowerPC Macs?

On May 24, 2009, at 5:56 PM, Rafal Czlonka wrote:

Rick Thomas wrote:
Adding snd-powermac to /etc/modules gets rid of the errors at boot time
from /etc/init.d/alsa-utils.

But it doesn't fix the "no sound" problem.

Adding snd-aoa instead of snd-powermac doesn't get rid of the error
messages and doesn't fix the "no-sound" problem, either.

That's obviously not the only module you're missing.
It would help if you could give some more details, e.g. what PowerPC
machine is it, which release are you using, etc.
I personally use snd-aoa (and some other modules) on my iBook G4
(PowerBook6,7) running unstable; snd-powermac worked for me couple
of years ago, but not the last time I tried it.

It's a PowerMac G4 "Silver" (deskside tower) running pretty-much "vanilla" Squeeze: fresh off the install disk.

With snd-powermac installed, and with an external speaker plugged into the "headphone" jack on the back of the computer, I can get sound, but *only* from the onboard speaker. The external speaker (looks like "headphone") remains silent.

Very peculiar!

If I were to file a bug report, which package should I file it against?



Here are the details:

rbthomas@macswell:~$ cat /proc/cpuinfo
processor       : 0
cpu             : 7410, altivec supported
temperature     : 36-39 C (uncalibrated)
clock           : 533.333332MHz
revision        : 0.3 (pvr 800c 1103)
bogomips        : 66.30
timebase        : 33290001
platform        : PowerMac
model           : PowerMac3,4
machine         : PowerMac3,4
motherboard     : PowerMac3,4 MacRISC2 MacRISC Power Macintosh
detected as     : 69 (PowerMac G4 Silver)
pmac flags      : 00000010
L2 cache        : 1024K unified
pmac-generation : NewWorld

rbthomas@macswell:~$ lsmod | grep snd
snd_powermac           47936  2
snd_aoa_i2sbus         22820  0
snd_pcm                79748  2 snd_powermac,snd_aoa_i2sbus
snd_page_alloc         12392  1 snd_pcm
snd_seq                57800  0
snd_timer              25508  2 snd_pcm,snd_seq
snd_seq_device         11020  1 snd_seq
snd 61876 10 snd_powermac,snd_aoa_i2sbus,snd_pcm,snd_seq,snd_timer,snd_seq_device
soundcore              10244  1 snd
snd_aoa_soundbus        9060  1 snd_aoa_i2sbus

rbthomas@macswell:~$ aptitude search alsa | grep '^i'
i   alsa-base                       - ALSA driver configuration files
i   alsa-utils                      - ALSA utilities
i A gstreamer0.10-alsa              - GStreamer plugin for ALSA
i A libesd-alsa0 - Enlightened Sound Daemon (ALSA) - Shared l i A libpt-1.10.10-plugins-alsa - Portable Windows Library Audio Plugin for i A libsdl1.2debian-alsa - Simple DirectMedia Layer (with X11 and ALS

Reply to: